Having low framerate with GZdoom

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

Having low framerate with GZdoom

Postby Plonkett » Fri Jun 22, 2018 5:48 pm

I just updated GZdoom to its latest version, and now I'm having lower framerate than ever before. It was nowhere near to this level until now. Any way to get better framerate?
Plonkett
 
Joined: 22 Jun 2018

Re: Having low framerate with GZdoom

Postby Graf Zahl » Fri Jun 22, 2018 6:02 pm

What's your hardware? The latest versions have some known issues with some older hardware, a solution is in the works for the next release.
User avatar
Graf Zahl
Lead GZDoom Developer
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Having low framerate with GZdoom

Postby Plonkett » Fri Jun 22, 2018 6:56 pm

[imgur]https://imgur.com/a/t82r5iw[/imgur]
Plonkett
 
Joined: 22 Jun 2018

Re: Having low framerate with GZdoom

Postby Graf Zahl » Sat Jun 23, 2018 2:06 am

The important thing is your graphics hardware, especially the OpenGL version.
User avatar
Graf Zahl
Lead GZDoom Developer
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Having low framerate with GZdoom

Postby wildweasel » Sat Jun 23, 2018 11:22 am

Graf Zahl wrote:The important thing is your graphics hardware, especially the OpenGL version.

Unless OP's installed their own graphics card, that model of HP computer has, at minimum, an ATI Radeon 4200 for integrated graphics (source). But we'd need OP to answer for certain.
User avatar
wildweasel
change o' pace.
Moderator Team Lead
 
Joined: 15 Jul 2003

Re: Having low framerate with GZdoom

Postby Plonkett » Sat Jun 23, 2018 11:31 am

Graphics card came with the computer.
Plonkett
 
Joined: 22 Jun 2018

Re: Having low framerate with GZdoom

Postby Graf Zahl » Sat Jun 23, 2018 11:54 am

Ok. That card would definitely be slow enough to be negatively affected by the recent change in the renderer. Although it nominally supports OpenGL 3.3, speed wise it is comparable to Intel's integrated GL 2.x chipsets.
User avatar
Graf Zahl
Lead GZDoom Developer
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Having low framerate with GZdoom

Postby Doris Pussleville » Sun Jul 01, 2018 10:25 pm

Greetings!

Framerate here also went to shit =(

Running latest GZDoom on Intel HD Graphics (i3 540 - OpenGL 2.1 supported), any workaround for this in the meanwhile?
Doris Pussleville
 

Re: Having low framerate with GZdoom

Postby Doris Pussleville » Sun Jul 01, 2018 10:45 pm

Hm... Interesting enough, I'm now messing around with the configurations, and by deactivating a few things (texture filtering, special effects and using Doom rendering), I could get acceptable framerate. But after killing every monster in the level (so that sound effects from demons, gun shots and stuff stop happening), the framerate goes back to shit after a while, and only by producing sound (armor/potion pickup, door opening, etc) gzdoom goes back to normal, and after a while, framerate drops again O.o
Doris Pussleville
 

Re: Having low framerate with GZdoom

Postby Graf Zahl » Mon Jul 02, 2018 1:28 am

Can you check a few older versions to see where it started? There was a change to the renderer in 3.4.0 which didn't play well with older hardware, this will be addressed with the next release.
User avatar
Graf Zahl
Lead GZDoom Developer
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Having low framerate with GZdoom

Postby Doris Pussleville » Mon Jul 02, 2018 7:22 pm

Ok, the exactly previous version worked wonderfully without any problems. Somehow GZDoom uses sound effects to keep the pace?

Given GZDoom seems to be throttling iItself when there isn't sound effects playing, I went further ahead and restored all settings to default, the application actually plays quite nicely as long as there are sound effects playing (For instance, having the chainsaw selected makes GZdoom to play at constant 60 fps without any drops at all).

Things gets even worse when fluidsynth is selected, maybe loading soundfonts somehow adds extreme overhead to GZDoom? When selecting Microsoft Wavetable, audio seems to work fine, but sometime I experience frame drops.

Finally, using the options from the menu to reset everything to defalt crashes GZDoom O.o

Here it's the Crash Report:
https://bin.smwcentral.net/u/26932/CrashReport.zip
Doris Pussleville
 

Re: Having low framerate with GZdoom

Postby Graf Zahl » Tue Jul 03, 2018 1:06 am

If FluidSynth gives you problems with performance your system is simply too weak. Of all the options for MIDI playback it is the one requiring the most CPU power. On old single-core systems this can be enough to affect performance.
User avatar
Graf Zahl
Lead GZDoom Developer
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Having low framerate with GZdoom

Postby phantombeta » Tue Jul 03, 2018 1:09 am

Doris Pussleville wrote:Ok, the exactly previous version worked wonderfully without any problems. Somehow GZDoom uses sound effects to keep the pace?

It doesn't.
Given GZDoom seems to be throttling iItself when there isn't sound effects playing, I went further ahead and restored all settings to default, the application actually plays quite nicely as long as there are sound effects playing (For instance, having the chainsaw selected makes GZdoom to play at constant 60 fps without any drops at all).

Have you checked if your computer is set to some power saving mode that throttles the CPU?
User avatar
phantombeta
In the meadow of sinful thoughts, every flower's a perfect one
 
Joined: 02 May 2013
Location: The United Soviet Socialist Dictatorship of Hueland
Discord: phantombeta#2461
Twitch ID: phantombeta_
Github ID: Doom2fan
Operating System: Windows 10/8.1/8 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: Having low framerate with GZdoom

Postby Doris Pussleville » Tue Jul 03, 2018 2:16 am

[quote]If FluidSynth gives you problems with performance your system is simply too weak.[/quote]

Yeah, that's likely the case. It's just weird that it plays nicely as long as there is sound effects being triggered. As the level gets silent, everything slows down. =(

[quote]Have you checked if your computer is set to some power saving mode that throttles the CPU?[/quote]

Yep, even on BIOS configs I have deactivated any power saving settings such as Speedstep or C# states, definately not a problem from my end in this regard. I've been pretty much using this CPU for months to run intensive tasks like accurate emulators on it. (for instance, higan and mednafen brutally eats CPU power, but I can still keep solid framerate on them with vertical sync on, though admittedly, the CPU literally runs in the limit and a few drops are perceived)

Probably it's just easier to wait for the workaround planned for the next release instead of looking for problems that might simply not exist. =)

Sorry for the condescending statements implying GZdoom throttles itself or that you guys have commited an oversight in this release. =S
I suppose it's easier to believe that rather than to admit the obsoleteness of my hardware :P
Doris Pussleville
 


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 3 guests