[Fixed] Dynamic Light Shadowmaps Blocked by Polyobjects Again

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Dynamic Light Shadowmaps Blocked by Polyobjects Again

Postby Dr. Van Nostrand » Sat Jul 11, 2020 1:59 pm

This is a follow up to this old bug report:
viewtopic.php?f=7&t=63018

I know I've seen this working properly in the past with an older version on my older machine but it seems to have broken at some point recently. I've attached a sample wad here.

Tested on Gzdoom 4.4.2 running the openGl renderer with an nvidia GeForce RTX 2080 Super with Max-Q Design.

Here's a short video showing what I see on my end:
https://drive.google.com/file/d/1DPoIlC ... sp=sharing
You do not have the required permissions to view the files attached to this post.
User avatar
Dr. Van Nostrand
 
Joined: 10 May 2015
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: Dynamic Light Shadowmaps Blocked by Polyobjects Again

Postby FishyClockwork » Thu Jul 16, 2020 10:26 am

Just to add my 2 cents.

It seems this bug appeared as early as 4.4.0. It used to work as intended in 4.3.3.
It doesn't seem to matter if it's OpenGL or Vulkan.

EDIT: To be clear, in 4.3.3 the shadows would get updated as the polyobject moves where now the shadow never changes.
User avatar
FishyClockwork
 
Joined: 23 Feb 2011

Re: Dynamic Light Shadowmaps Blocked by Polyobjects Again

Postby Graf Zahl » Sat Oct 17, 2020 6:59 am

fixed.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests