ZDoom DOS and SB16/Wave blaster

ZDoom LE, Pentium 133's, Windows 98, and DOS 3.1 all go here! A bygone era, of particular interest to some folks.
Gordon228
Posts: 30
Joined: Sun Mar 19, 2006 11:21 pm

ZDoom DOS and SB16/Wave blaster

Post by Gordon228 »

i have an odd question/problem with a dos port of zdoom in that it dose not detect that i have a midi card installed on my Pentium FreeDOS machine. the sound card in question is the sound blaster 16 with the attached wave blaster. maybe there is an updated ZDoom for dos that fixes this or is it a lost cause? also want to know your takes on this as it is funny to have an older zdoom running in dos.
User avatar
drfrag
Vintage GZDoom Developer
Posts: 3142
Joined: Fri Apr 23, 2004 3:51 am
Location: Spain

Re: ZDoom DOS and SB16/Wave blaster

Post by drfrag »

ZDoom for DOS (i think it was 1.17c) didn't support MIDI music.
Gordon228
Posts: 30
Joined: Sun Mar 19, 2006 11:21 pm

Re: ZDoom DOS and SB16/Wave blaster

Post by Gordon228 »

then why dose it have SNS_MIDIDEVICE command and also SND_LISTMIDIDEVICES command? strangely it looks for an AUTOEXEc.BAT but maybe removing the need to find it might solve all my problems?
User avatar
wildweasel
Posts: 21706
Joined: Tue Jul 15, 2003 7:33 pm
Preferred Pronouns: He/Him
Operating System Version (Optional): A lot of them
Graphics Processor: Not Listed

Re: ZDoom DOS and SB16/Wave blaster

Post by wildweasel »

Likely those are holdovers from the Windows version, since I imagine they'd be compiled from the same source.

Return to “Legacy Discussion”