[4.9.0] A_ChangeModel non-existent modeldef causes engine freeze

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.
User avatar
FishyClockwork
Posts: 732
Joined: Wed Feb 23, 2011 11:04 am
Preferred Pronouns: No Preference

[4.9.0] A_ChangeModel non-existent modeldef causes engine freeze

Post by FishyClockwork »

If I specify a invalid modeldef to use via A_ChangeModel, the engine will lock up/freeze and I have to kill gzdoom via Task Manager.
I would prefer if it printed an error message instead. Saying the modeldef specified doesn't exist or something.

Load this zscript example for yourself, summon Test, close the console and gzdoom should freeze:

Code: Select all

version "4.9.0"

class Test : Actor
{
	States
	{
	Spawn:
		PLAY A -1 NoDelay A_ChangeModel("bogus");
		Stop;
	}
}
User avatar
Shiny Metagross
Posts: 172
Joined: Wed Apr 02, 2014 10:00 pm
Location: USA

Re: [4.9.0] A_ChangeModel non-existent modeldef causes engine freeze

Post by Shiny Metagross »

This shouldn't be too hard to fix, but I may not be able to get to this immediately. I'll respond here again once I have a fix. Unless of course someone beats me to it.
User avatar
Shiny Metagross
Posts: 172
Joined: Wed Apr 02, 2014 10:00 pm
Location: USA

Re: [4.9.0] A_ChangeModel non-existent modeldef causes engine freeze

Post by Shiny Metagross »

Return to “Closed Bugs [GZDoom]”