[4.8.2] Oddly specific crash on Plutonia MAP06

Is there something that doesn't work right in the latest GZDoom? Post about it here.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!
User avatar
MFG38
Posts: 409
Joined: Sun Apr 14, 2019 8:26 am
Graphics Processor: nVidia (Modern GZDoom)
Location: Finland

[4.8.2] Oddly specific crash on Plutonia MAP06

Post by MFG38 »

So I was just playing Plutonia casually and started getting crashes upon trying to enter the final area of MAP06 (Baron's Den). The crashes seemed to mostly occur when facing towards the center of the area - namely, approaching it while facing in its direction. What makes this crash interesting is that it only occurred when the game was running fullscreen - I was able to bypass it by running in windowed mode for the remainder of the map. But still, I felt this was worth reporting. I tried having GZDoom produce a crash log by adding the +logfile parameter once but it gave me nothing useful.

Possibly relevant information:
GPU: AMD onboard graphics (Ryzen 5600G)
Rendering backend on GZDoom: OpenGL
Screen resolution: 1920x1080
GZDoom fullscreen resolution: Native
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48376
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: [4.8.2] Oddly specific crash on Plutonia MAP06

Post by Graf Zahl »

What precisely did you get when it crashed?
User avatar
MFG38
Posts: 409
Joined: Sun Apr 14, 2019 8:26 am
Graphics Processor: nVidia (Modern GZDoom)
Location: Finland

Re: [4.8.2] Oddly specific crash on Plutonia MAP06

Post by MFG38 »

Graf Zahl wrote: Fri Oct 21, 2022 10:47 am What precisely did you get when it crashed?
The program just froze for about 5 seconds and then terminated itself. No error messages of any sort. If that's what you mean.
User avatar
MFG38
Posts: 409
Joined: Sun Apr 14, 2019 8:26 am
Graphics Processor: nVidia (Modern GZDoom)
Location: Finland

Re: [4.8.2] Oddly specific crash on Plutonia MAP06

Post by MFG38 »

Okay, I may have found the cause of the crashing - it's likely related to the fuzz effect rendering being set to "Software" mode. Encountered the crash again on MAP08, similar results: game crashed when running in fullscreen but not in windowed mode. Just for the hell of it, I changed that setting to something else and back while looking at a Spectre corpse and that crashed the game again (game was running in fullscreen when I ran this experiment).
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48376
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: [4.8.2] Oddly specific crash on Plutonia MAP06

Post by Graf Zahl »

Please don't tell me that AMD has another shader miscompilation... :(

Return to “Bugs [GZDoom]”