What opengl version do the latest Llamasoft games require?

If it's not ZDoom, it goes here.
invictius
Posts: 400
Joined: Fri Aug 03, 2012 6:44 am

What opengl version do the latest Llamasoft games require?

Post by invictius »

Specifically Polybius, I googled for a program that would tell you the opengl requirements of the exe but there really doesn't seem to be anything that does it. I just tried the game on a modern cpu but opengl2 video card, maybe it uses opengl3 or 4.5.
User avatar
wildweasel
Moderator Team Lead
Posts: 21590
Joined: Tue Jul 15, 2003 7:33 pm
Preferred Pronouns: He/Him
Operating System Version (Optional): Win10 22H2, Win11 22H2, macOS 11.7
Graphics Processor: nVidia with Vulkan support

Re: What opengl version do the latest Llamasoft games require?

Post by wildweasel »

Polybius System Requirements page on Steam wrote:System Requirements

Minimum:
OS: Win 8/8.1, Win 10
Processor: 2.5 GHz
Graphics: GTX 960 or AMD equivalent
DirectX: Version 10
Storage: 1605 MB available space
Sound Card: DirectX Compatible Soundcard
Additional Notes: if playing in VR ensure your system conforms to Oculus' minimum VR specs.
I'm leaning on, "Whatever a GTX 960 supports."
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48537
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: What opengl version do the latest Llamasoft games require?

Post by Graf Zahl »

I wouldn't expect anything recent to require at least OpenGL 3.3. This is the baseline feature set for modern development - everything older is missing critical base features that are being taken for granted these days.

With an OpenGL 2 GPU I wouldn't actually bother with modern games (and modern remasters of old games) anymore - it's too old and too lacking, even for simple stuff.
If someone says Geforce GTX 9xx as minimum there's really no point at all even trying to run it on anything that doesn't support DX12 and Vulkan.
User avatar
sinisterseed
Posts: 1349
Joined: Tue Nov 05, 2019 6:48 am
Preferred Pronouns: He/Him
Graphics Processor: nVidia with Vulkan support

Re: What opengl version do the latest Llamasoft games require?

Post by sinisterseed »

wildweasel wrote: Thu Aug 11, 2022 7:05 pm
Polybius System Requirements page on Steam wrote:System Requirements

Minimum:
OS: Win 8/8.1, Win 10
Processor: 2.5 GHz
Graphics: GTX 960 or AMD equivalent
DirectX: Version 10
Storage: 1605 MB available space
Sound Card: DirectX Compatible Soundcard
Additional Notes: if playing in VR ensure your system conforms to Oculus' minimum VR specs.
I'm leaning on, "Whatever a GTX 960 supports."
Which means OpenGL support all the way to 4.6, DX12, and Vulkan (obviously) in this case, just like the 950 - https://www.techpowerup.com/gpu-specs/g ... -960.c2637

And also the oldest non-raytracing generation of cards still actively supported by drivers. Not even worth going below the 900 series as the rest have all been dropped and one won't find anything worthwhile there anymore.
invictius
Posts: 400
Joined: Fri Aug 03, 2012 6:44 am

Re: What opengl version do the latest Llamasoft games require?

Post by invictius »

Graf Zahl wrote: Fri Aug 12, 2022 1:17 am I wouldn't expect anything recent to require at least OpenGL 3.3. This is the baseline feature set for modern development - everything older is missing critical base features that are being taken for granted these days.

With an OpenGL 2 GPU I wouldn't actually bother with modern games (and modern remasters of old games) anymore - it's too old and too lacking, even for simple stuff.
If someone says Geforce GTX 9xx as minimum there's really no point at all even trying to run it on anything that doesn't support DX12 and Vulkan.
I'd be interested in what it does require because it's such an incredibly simple game. I get 90fps at 1080p on a first gen i7 and 710. Might be time to haul the retro pc's out of the basement...
User avatar
Kinsie
Posts: 7356
Joined: Fri Oct 22, 2004 9:22 am
Graphics Processor: nVidia with Vulkan support
Location: MAP33

Re: What opengl version do the latest Llamasoft games require?

Post by Kinsie »

invictius wrote: Fri Aug 12, 2022 6:01 pm I'd be interested in what it does require because it's such an incredibly simple game. I get 90fps at 1080p on a first gen i7 and 710. Might be time to haul the retro pc's out of the basement...
It's also designed to run at 120fps on VR headsets on console hardware. Asset complexity is only one part of the puzzle.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48537
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: What opengl version do the latest Llamasoft games require?

Post by Graf Zahl »

invictius wrote: Fri Aug 12, 2022 6:01 pm
Graf Zahl wrote: Fri Aug 12, 2022 1:17 am I wouldn't expect anything recent to require at least OpenGL 3.3. This is the baseline feature set for modern development - everything older is missing critical base features that are being taken for granted these days.

With an OpenGL 2 GPU I wouldn't actually bother with modern games (and modern remasters of old games) anymore - it's too old and too lacking, even for simple stuff.
If someone says Geforce GTX 9xx as minimum there's really no point at all even trying to run it on anything that doesn't support DX12 and Vulkan.
I'd be interested in what it does require because it's such an incredibly simple game.
"Incredibly simple game is rather meaningless. The main issue is that crucial features for forward-compatible graphics programming were only introduced in GL 3.3 and on macOS you cannot use post GL 2.1 features with a compatibility context so you have to make the choice to either support old potatoes or Macs.

Return to “Off-Topic”