4.8.0: i_soundinbackground not working?

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE/EDuke32/Raze? Did your computer break? Ask here.

Moderator: GZDoom Developers

Forum rules
Contrary to popular belief, we are not all-knowing-all-seeing magical beings!

If you want help you're going to have to provide lots of info. Like what is your hardware, what is your operating system, what version of GZDoom/LZDoom/whatever you're using, what mods you're loading, how you're loading it, what you've already tried for fixing the problem, and anything else that is even remotely relevant to the problem.

We can't magically figure out what it is if you're going to be vague, and if we feel like you're just wasting our time with guessing games we will act like that's what you're really doing and won't help you.
User avatar
Rachael
Admin
Posts: 13110
Joined: Tue Jan 13, 2004 1:31 pm
Preferred Pronouns: She/Her

4.8.0: i_soundinbackground not working?

Post by Rachael »

One feature that became unexpectedly popular was i_soundinbackground - which prior to 4.8.0 had the unexpected consequence of pausing the game when it was false.

In 4.8.0 this changed. I might've been too busy to act on the foresight that this would've caused confusion - and I also forgot to add it as an option to the menu.

To restore i_soundinbackground's original behavior, i_pauseinbackground must be set to false. The two variables are now split and act independently. If you have pause in the background enabled then the game stops - period - sounds included. However, if pause in background is disabled but sound is also disabled, the game will still run, just without sound.

This will be addressed in the 4.8.1 release.

Return to “Technical Issues”