gzdoom sets monitor refresh rate to 60hz in fullscreen

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE/EDuke32/Raze? Did your computer break? Ask here.

Moderator: GZDoom Developers

Forum rules
Contrary to popular belief, we are not all-knowing-all-seeing magical beings!

If you want help you're going to have to provide lots of info. Like what is your hardware, what is your operating system, what version of GZDoom/LZDoom/whatever you're using, what mods you're loading, how you're loading it, what you've already tried for fixing the problem, and anything else that is even remotely relevant to the problem.

We can't magically figure out what it is if you're going to be vague, and if we feel like you're just wasting our time with guessing games we will act like that's what you're really doing and won't help you.
User avatar
Marrub
 
 
Posts: 1167
Joined: Tue Feb 26, 2013 2:48 pm
Preferred Pronouns: They/Them
Operating System Version (Optional): Arch Linux
Graphics Processor: ATI/AMD with Vulkan/Metal Support

gzdoom sets monitor refresh rate to 60hz in fullscreen

Post by Marrub »

on windows with a high refresh rate monitor (>60hz) gzdoom will force the monitor to go into 59.940hz mode if you enable fullscreen regardless of vsync/max fps/etc. settings

this causes a delay as the monitor synchronizes the settings when launching, but besides that, restricts gzdoom to running at 60fps in fullscreen, which kind of defeats the point of using fullscreen

there should certainly either be an option to change the refresh rate used in fullscreen or it should just use the monitor's highest (or even whatever was applied before launching)
User avatar
Player701
 
 
Posts: 1530
Joined: Wed May 13, 2009 3:15 am
Graphics Processor: nVidia with Vulkan support
Location: Russia

Re: gzdoom sets monitor refresh rate to 60hz in fullscreen

Post by Player701 »

I don't have this issue, my new monitor stays at 144 Hz while GZDoom is running. Maybe this only affects AMD graphics cards?
User avatar
phantombeta
Posts: 2030
Joined: Thu May 02, 2013 1:27 am
Graphics Processor: nVidia with Vulkan support
Location: Brazil

Re: gzdoom sets monitor refresh rate to 60hz in fullscreen

Post by phantombeta »

This sounds like a driver or window manager bug. As far as I know, GZDoom only supports borderless and does not set video modes anymore.
User avatar
Marrub
 
 
Posts: 1167
Joined: Tue Feb 26, 2013 2:48 pm
Preferred Pronouns: They/Them
Operating System Version (Optional): Arch Linux
Graphics Processor: ATI/AMD with Vulkan/Metal Support

Re: gzdoom sets monitor refresh rate to 60hz in fullscreen

Post by Marrub »

phantombeta wrote:This sounds like a driver or window manager bug. As far as I know, GZDoom only supports borderless and does not set video modes anymore.
considering there is only one driver and one window manager on windows i would hope this not to be the case
Player701 wrote:I don't have this issue, my new monitor stays at 144 Hz while GZDoom is running. Maybe this only affects AMD graphics cards?
might be? but did you set the game to fullscreen with the vulkan renderer enabled? those are the exact circumstances where it changes
User avatar
Player701
 
 
Posts: 1530
Joined: Wed May 13, 2009 3:15 am
Graphics Processor: nVidia with Vulkan support
Location: Russia

Re: gzdoom sets monitor refresh rate to 60hz in fullscreen

Post by Player701 »

Marrub wrote:might be? but did you set the game to fullscreen with the vulkan renderer enabled? those are the exact circumstances where it changes
Yes, I'm using Vulkan and I'm playing in fullscreen. The monitor is running at 144 Hz as expected, and the OSD confirms that.
User avatar
Marrub
 
 
Posts: 1167
Joined: Tue Feb 26, 2013 2:48 pm
Preferred Pronouns: They/Them
Operating System Version (Optional): Arch Linux
Graphics Processor: ATI/AMD with Vulkan/Metal Support

Re: gzdoom sets monitor refresh rate to 60hz in fullscreen

Post by Marrub »

Player701 wrote:
Marrub wrote:might be? but did you set the game to fullscreen with the vulkan renderer enabled? those are the exact circumstances where it changes
Yes, I'm using Vulkan and I'm playing in fullscreen. The monitor is running at 144 Hz as expected, and the OSD confirms that.
yeah it must be an AMD issue then. though i don't know what would possibly cause that, i'm using stock settings on my drivers
User avatar
Rachael
Admin
Posts: 13208
Joined: Tue Jan 13, 2004 1:31 pm
Preferred Pronouns: She/Her

Re: gzdoom sets monitor refresh rate to 60hz in fullscreen

Post by Rachael »

Are you on Windows at the moment? (You've put in your profile Linux, but you're talking in this thread like Windows, so I am not sure)

And if you are - is your display driver set up to adjust the resolution for lower resolution modes? If so - set it to Display scaling.

I don't have an ATI/AMD but I can use my Intel control panel to illustrate what I mean. There should be something similar in ATI/AMD.

dpJudas
 
 
Posts: 2923
Joined: Sat May 28, 2016 1:01 pm

Re: gzdoom sets monitor refresh rate to 60hz in fullscreen

Post by dpJudas »

The vulkan backend does not use the vulkan exclusive fullscreen feature.

All that GZDoom does (both OpenGL and Vulkan) is to remove the window decorations (title bar, borders, etc.) and position the window to exactly cover the screen. Windows detects this, turns the DWM off and renders directly to the screen. If there is any change in refresh rate then that's either an issue with Windows or the display driver as GZDoom doesn't request any mode switches. My best guess is it is an AMD driver bug - try upgrade the driver and if that doesn't help then report the issue to AMD. Or report it to Microsoft. In any case, it isn't a bug in GZDoom that's for sure.
User avatar
Marrub
 
 
Posts: 1167
Joined: Tue Feb 26, 2013 2:48 pm
Preferred Pronouns: They/Them
Operating System Version (Optional): Arch Linux
Graphics Processor: ATI/AMD with Vulkan/Metal Support

Re: gzdoom sets monitor refresh rate to 60hz in fullscreen

Post by Marrub »

Rachael wrote:Are you on Windows at the moment? (You've put in your profile Linux, but you're talking in this thread like Windows, so I am not sure)
yes, I'm on windows, i mainly test things on linux though
Rachael wrote:And if you are - is your display driver set up to adjust the resolution for lower resolution modes? If so - set it to Display scaling.
there's no such option anywhere in the radeon control panel, it doesn't manage displays at all except the ability to scale the display or globally enable vsync (both of which i have disabled)
dpJudas wrote:Windows detects this, turns the DWM off and renders directly to the screen. If there is any change in refresh rate then that's either an issue with Windows or the display driver as GZDoom doesn't request any mode switches.
it seems unlikely that it isn't an issue with gzdoom as it is the only game on my entire system that does this
dpJudas wrote:My best guess is it is an AMD driver bug - try upgrade the driver and if that doesn't help then report the issue to AMD.
it's consistent across driver versions (including the latest, which i have installed)
User avatar
Marrub
 
 
Posts: 1167
Joined: Tue Feb 26, 2013 2:48 pm
Preferred Pronouns: They/Them
Operating System Version (Optional): Arch Linux
Graphics Processor: ATI/AMD with Vulkan/Metal Support

Re: gzdoom sets monitor refresh rate to 60hz in fullscreen

Post by Marrub »

also while i'm here i should mention another issue: for some reason, across drivers and operating systems, vulkan gzdoom rotates everything drawn in 2d slightly, which is immensely distressing, as my wife's computer doesn't do this at all under the exact same circumstances (but a different GPU which is nvidia)

it's most noticeable with high contrast density fonts like the one used in lithium:
bLUEbYTE
Posts: 134
Joined: Fri Nov 15, 2019 4:28 am
Graphics Processor: Intel with Vulkan/Metal Support
Location: Australia

Re: gzdoom sets monitor refresh rate to 60hz in fullscreen

Post by bLUEbYTE »

Can confirm this issue. I'm on Windows 11 and have a Radeon 6600 running with latest drivers. No other game I've tried does this, but after running GZDoom my monitor refresh rate gets reset to 60 Hz. Normaly it's 120... pretty annoying
dpJudas
 
 
Posts: 2923
Joined: Sat May 28, 2016 1:01 pm

Re: gzdoom sets monitor refresh rate to 60hz in fullscreen

Post by dpJudas »

Confirm the refresh rate or the rotation? That it slightly rotates the output is fascinating!
bLUEbYTE
Posts: 134
Joined: Fri Nov 15, 2019 4:28 am
Graphics Processor: Intel with Vulkan/Metal Support
Location: Australia

Re: gzdoom sets monitor refresh rate to 60hz in fullscreen

Post by bLUEbYTE »

No rotation in my case, just the revert to 60Hz. After launching & quitting the game.
Happen with both GL & Vulkan backends.

Return to “Technical Issues”