[gda4e791a3] "Quick Turn" loses its interpolation...

Is there something that doesn't work right in the latest GZDoom? Post about it here.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!
User avatar
sinisterseed
Posts: 1349
Joined: Tue Nov 05, 2019 6:48 am
Preferred Pronouns: He/Him
Graphics Processor: nVidia with Vulkan support

[gda4e791a3] "Quick Turn" loses its interpolation...

Post by sinisterseed »

...after using the mouse.

I have to use the keyboard to turn left/right or something for it to come back, but after I use the mouse again it returns. This is different from Raze where the interpolation for quick turning doesn't get lost after using the mouse, which makes me think this is a GZDoom bug.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48538
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: [gda4e791a3] "Quick Turn" loses its interpolation...

Post by Graf Zahl »

I don't think this is fixable without redoing the entire code involved here. The mouse movement totally bypasses the input code and will screw up any movement induced through the ticcmd. This was what made us decide for Raze to not copy this code but handling it differently.

Return to “Bugs [GZDoom]”