DemonChunk FLOORCLIP broken?

Is there something that doesn't work right in the latest GZDoom? Post about it here.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!
CaptainToenail
Posts: 3975
Joined: Fri Jul 06, 2007 9:16 am

DemonChunk FLOORCLIP broken?

Post by CaptainToenail »

Riddle me this ZDoom forums.

If all actors derived from DemonChunk (the giblets of Hexen's green Chaos Serpent) have the FLOORCLIP flag, then why don't they actually clip into the water?

Code: Select all

ACTOR DemonChunk
{
  Radius 5
  Height 5
  +NOBLOCKMAP
  +DROPOFF
  +MISSILE
  +CORPSE
  +FLOORCLIP
  +NOTELEPORT
}


Is this a bug, or am I missing something?
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48519
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: DemonChunk FLOORCLIP broken?

Post by Graf Zahl »

What renderer is this?
CaptainToenail
Posts: 3975
Joined: Fri Jul 06, 2007 9:16 am

Re: DemonChunk FLOORCLIP broken?

Post by CaptainToenail »

Above screenshot is in software mode.

It clips into the water on hardware mode with varying depth depending on the 'adjust sprite clipping' setting. (maybe it's not actually floor clipping into the liquid and that's just the 'adjust sprite clipping' effect)


Now what is interesting, is I have a custom terrain defined with a deep 32 units of depth. This is used in black areas to hide the corpses of any flying enemies that may land in it.

Code: Select all

terrain darkvoid
{
	footclip		32
	liquid
}
You would expect the demonchunk bits to be submerged completely, however they show the same clipping behaviour as regular water? (or is that just the 'adjust sprite clipping' setting taking effect? Really strange.


EDIT: pictures are better than words.

Both of these below were taken in hardware mode with 'adjust sprite clipping' set to 'Always' When set to never, the chunks clip into all floor surfaces regardless of the terrain.

Return to “Bugs [GZDoom]”