Setting a CVar too many times freezes/crashes.

These bugs do plan to be resolved, when they can be.

Moderator: GZDoom Developers

Guest

Setting a CVar too many times freezes/crashes.

Post by Guest »

Now, I know everything about the event handler screams [Don't do that], but bear with me here. I'm using code elsewhere where SetString/SetInt is called only 2 times per WorldThingDamaged call, and only under specific conditions, yet this still happens if multiple monsters are killed at the same time (though I have to use Russian Overkill for that).

How to reproduce using example below and what happens:
MAP01, UV: start game, type "kill monsters" in console, freeze. Potentially crash to desktop. If you don't crash, hit escape. You can hear the menu open/close sound.
E1M1, HMP: same as above, but phantombeta said this reliably crashes to desktop with error reporter. 8 monsters do, to be precise.

Example: https://drive.google.com/open?id=1dQ8v1 ... s1N7lHAnFS

P.S. Intially I got this error: "Tried to transmit to another node". Then I somehow got another error in the format "NetUpdate: Node %d missed too many tics".
Guest

Re: Setting a CVar too many times freezes/crashes.

Post by Guest »

Whoops, forgot to mention I tested this on gzdoom-x64-g4.3pre-597-g60026ba4f. Sorry 'bout that.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48375
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Setting a CVar too many times freezes/crashes.

Post by Graf Zahl »

Server CVARs require sending the change through the network interface. But for performance reasons that interface's buffer is static and has limited size. Your repeated changing of the CVAR means that the buffer simply overflows, and I'm sorry to say the code involved here is in a state where fixing such issues is not a trivial thing.
Guest

Re: Setting a CVar too many times freezes/crashes.

Post by Guest »

Good to know, thanks. I've worked around this issue and it no longers crashes now. My implementation was wrong.
User avatar
Dylan Simpson
Posts: 6
Joined: Mon Dec 30, 2019 7:15 am

Re: Setting a CVar too many times freezes/crashes.

Post by Dylan Simpson »

Hmm, thanks for the tip, it helped
User avatar
m8f
 
 
Posts: 1422
Joined: Fri Dec 29, 2017 4:15 am
Location: Siberia (UTC+7)

Re: Setting a CVar too many times freezes/crashes.

Post by m8f »

Just linking here a thread that was closed as a duplicate of this: viewtopic.php?f=7&t=66943

Return to “On Hold Bugs”