[4.2.4]Scrambled Voxel Colors When Models Are On

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!
User avatar
TheMightyHeracross
Posts: 2100
Joined: Sun Aug 18, 2013 9:41 am
Location: Philadelphia, PA

[4.2.4]Scrambled Voxel Colors When Models Are On

Post by TheMightyHeracross »

This happens in the palette versions of both the Carmack and Softpoly renderers. Curiously, this only happens when models are turned on- when models are off the voxel models have correct colors even in these renderers.

Models on:
Image

Models off:
Image

Test wad used:
http://teamhellspawn.com/zdoom_vox.zip
User avatar
phantombeta
Posts: 2009
Joined: Thu May 02, 2013 1:27 am
Graphics Processor: nVidia with Vulkan support

Re: [4.2.4]Scrambled Voxel Colors When Models Are On

Post by phantombeta »

If you look at the Chaingun, you can notice they seem to be drawn differently - the one with models enabled is more... Cube-ey.
Which leads to the conclusion that what's happening here is that it's trying to render the OpenGL renderer's mesh conversions instead of using the normal voxel rendering code.
Unfortunately, the renderers are not my area of expertise, so I can't tell you why it's doing that, nor can I fix it.

Return to “Classic ("Carmack") Software Renderer Bugs”