Partial invisibility kills the framerate

Bugs with GZDoom Vintage builds. Same rules apply as with all other bug reports fora.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!
dgzoom
Posts: 18
Joined: Wed Jul 24, 2019 1:17 am
Graphics Processor: nVidia (Modern GZDoom)

Partial invisibility kills the framerate

Post by dgzoom »

OS: Windows 7, 64-bit
Graphics chipset: ATI Radeon HD 4870
Driver: AMD Catalyst 13.9
Resolution: Any

LZDoom: 3.82.0.0
Renderer: OpenGL (works fine with software)

Default settings except for hardware video.

Picking up partial invisibility lowers the framerate from 200 to 16 and switching maps or starting a new game keeps it low. I have only tested it in Doom 2, map 7.

This might be another issue of my graphics card, though. :p
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 49066
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Partial invisibility kills the framerate

Post by Graf Zahl »

What happens if you change the render mode for this feature in the Display Options menu? The default is an unusual blending mode, and considering the "quality" of the driver it wouldn't surprise me if this was at fault.
dgzoom
Posts: 18
Joined: Wed Jul 24, 2019 1:17 am
Graphics Processor: nVidia (Modern GZDoom)

Re: Partial invisibility kills the framerate

Post by dgzoom »

I deleted the settings file, started in software mode.

Change rendering output
Hardware acceleration: DOOM Software Renderer (default), Software canvas: Direct3D (default)
High FPS
Hardware acceleration: OpenGL-accelerated, Software canvas: Direct3D (default)
Restart: Low FPS
Hardware acceleration: OpenGL-accelerated, Software canvas: OpenGL
Restart: Low FPS

I'm just reporting this in case others have the same issue.. I have ordered a new card now.
User avatar
drfrag
Vintage GZDoom Developer
Posts: 3141
Joined: Fri Apr 23, 2004 3:51 am
Location: Spain

Re: Partial invisibility kills the framerate

Post by drfrag »

Yep, i changed the default to software. Looks like it's a driver bug.
Under OpenGL options change fuzz style to shadow or something else.
BTW i think this should go under Vintage build/LZDoom bugs.
dgzoom
Posts: 18
Joined: Wed Jul 24, 2019 1:17 am
Graphics Processor: nVidia (Modern GZDoom)

Re: Partial invisibility kills the framerate

Post by dgzoom »

Sweet. Fuzz style: Anything but software is fine.

Thanks a bunch.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 49066
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Partial invisibility kills the framerate

Post by Graf Zahl »

drfrag wrote:Yep, i changed the default to software. Looks like it's a driver bug.
Under OpenGL options change fuzz style to shadow or something else.
BTW i think this should go under Vintage build/LZDoom bugs.
For a legacy build you should really not default to a more costly setting. The default shadow style was mainly chosen because it is a very cheap effect that's always hardware supported - even on the most ancient graphics hardware.
User avatar
drfrag
Vintage GZDoom Developer
Posts: 3141
Joined: Fri Apr 23, 2004 3:51 am
Location: Spain

Re: Partial invisibility kills the framerate

Post by drfrag »

Hey i didn't know it was that expensive. On ancient hardware it would revert to shadow anyway but that driver reports the feature as supported and it's broken.
I want it to look as in software, the other default is safe but it's not optimal. I did the same for the lightning mode.
Since there's a problem he could have gone and change the settings but he didn't, with shadow as default people could go and change it as well but many times they won't do it and get a suboptimal experience (but i don't mean that this setting it's optimal). Besides the default renderer is software anyway in LZDoom.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 49066
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Partial invisibility kills the framerate

Post by Graf Zahl »

So let me get this straight: You make a special build for legacy hardware - and then set everything to high end options? As a user I'd expect such a thing to be optimized by default for the hardware it's intended to run on.

Seriously, the reason why the default lighting mode is "Doom" is that this all comes from a time when GL 3.3 was the high end and wasn't performant enough to have these options on unconditionally.

Of course it's your project and ultimately your decision but with the intended mission of the port you have to always keep in mind that you have to compromise for the low end.
User avatar
drfrag
Vintage GZDoom Developer
Posts: 3141
Joined: Fri Apr 23, 2004 3:51 am
Location: Spain

Re: Partial invisibility kills the framerate

Post by drfrag »

It was a bug hidden by the old default, the fallback was not working for GL 2. I've changed the default to something cheaper as well.

Return to “Vintage Build Bugs”