New texture refactor broke translucency on single-file texs

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!
User avatar
ZZYZX
 
 
Posts: 1382
Joined: Sun Oct 14, 2012 1:43 am
Location: Ukraine

New texture refactor broke translucency on single-file texs

Post by ZZYZX »

When I say single-file, I'm referring to those in textures directory or inside TX_ markers.
Example wad attached. The image should be translucent.

It only looks correct with vid_rendermode 3, in all other renderers it's differently non-translucent.
Rendermode 1: https://i.imgur.com/3ydKM9F.png
Rendermode 4,0,2: https://i.imgur.com/xdowJep.png
Rendermode 3: https://i.imgur.com/3IypTsk.png

Reported against cc52f8937
You do not have the required permissions to view the files attached to this post.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48326
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: New texture refactor broke translucency on single-file t

Post by Graf Zahl »

Fixed for the hardware renderer. Why the true color software renderer isn't doing this right, but the softpoly renderer is, is something to be answered by someone else, preferably dpJudas.
dpJudas
 
 
Posts: 2890
Joined: Sat May 28, 2016 1:01 pm

Re: New texture refactor broke translucency on single-file t

Post by dpJudas »

I have no idea why it does this for the true color software renderer. It probably picks the wrong drawer.

Return to “Classic ("Carmack") Software Renderer Bugs”