[HS] Textures dissapear when changing video mode

Bugs with GZDoom Vintage builds. Same rules apply as with all other bug reports fora.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!
User avatar
drfrag
Vintage GZDoom Developer
Posts: 3141
Joined: Fri Apr 23, 2004 3:51 am
Location: Spain

[HS] Textures dissapear when changing video mode

Post by drfrag »

All versions affected (from 1.8.4 to latest SVN). With DTS-T.pk3 in MAP02 (has rain and fog) when changing video mode all textures dissapear and no more rain. Just changing to fullscreen triggers it.

https://www.doomworld.com/idgames/level ... wads/dts-t
Screenshot_Doom_20180213_184324.png
Last edited by drfrag on Mon Feb 19, 2018 6:08 am, edited 2 times in total.
_mental_
 
 
Posts: 3812
Joined: Sun Aug 07, 2011 4:32 am

Re: [HS] Textures dissapear when changing video mode

Post by _mental_ »

Works fine for me using the latest code. Also tried 1.8.6, 2.2.0, 3.2.5 without an issue, fullscreen and windowed.
What's the hardware? Was something else loaded along with DTS-T.pk3?
User avatar
drfrag
Vintage GZDoom Developer
Posts: 3141
Joined: Fri Apr 23, 2004 3:51 am
Location: Spain

Re: [HS] Textures dissapear when changing video mode

Post by drfrag »

No, actually happens with both intel and ati old GL 2 cards and only on maps with rain and fog so i don't think it's a driver problem. I started with default settings and just switching to fullscreen/windowed @640 makes the textures dissapear. May be i should try with an nvidia card.
Edit: HS stands for Holy Shit BTW.
_mental_
 
 
Posts: 3812
Joined: Sun Aug 07, 2011 4:32 am

Re: [HS] Textures dissapear when changing video mode

Post by _mental_ »

I see. You should mention the legacy render path in OP. It's unrelated to particular hardware indeed.
User avatar
drfrag
Vintage GZDoom Developer
Posts: 3141
Joined: Fri Apr 23, 2004 3:51 am
Location: Spain

Re: [HS] Textures dissapear when changing video mode

Post by drfrag »

I didn't mention it since it happens on all versions even before the legacy render path existed.
User avatar
drfrag
Vintage GZDoom Developer
Posts: 3141
Joined: Fri Apr 23, 2004 3:51 am
Location: Spain

Re: [HS] Textures dissapear when changing video mode

Post by drfrag »

I've tried again and apparently only happens on MAP02, not on MAP03. Warping to any other map with the MAP command restores the textures.
I'm not sure about it affecting only the LRP.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 49066
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: [HS] Textures dissapear when changing video mode

Post by Graf Zahl »

Moved this because it no longer applies to the modern build.
User avatar
drfrag
Vintage GZDoom Developer
Posts: 3141
Joined: Fri Apr 23, 2004 3:51 am
Location: Spain

Re: [HS] Textures dissapear when changing video mode

Post by drfrag »

And i deleted the attachment earlier today becouse i assumed it was not going to be fixed.

Return to “Vintage Build Bugs”