No sound from behind

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE/EDuke32/Raze? Did your computer break? Ask here.

Moderator: GZDoom Developers

Forum rules
Contrary to popular belief, we are not all-knowing-all-seeing magical beings!

If you want help you're going to have to provide lots of info. Like what is your hardware, what is your operating system, what version of GZDoom/LZDoom/whatever you're using, what mods you're loading, how you're loading it, what you've already tried for fixing the problem, and anything else that is even remotely relevant to the problem.

We can't magically figure out what it is if you're going to be vague, and if we feel like you're just wasting our time with guessing games we will act like that's what you're really doing and won't help you.
Evil Space Tomato
Posts: 78
Joined: Tue Jul 20, 2004 7:56 pm
Graphics Processor: nVidia with Vulkan support

No sound from behind

Post by Evil Space Tomato »

I get no sound from behind me, this occurs in zdoom and its child ports (gzdoom, skulltag, zandronum).
Left and right channels work just fine but once a sound start closer to directly behind me it quickly fades to 0% volume
However in DSDA doom I can hear stuff from behind me.
I used to have a 5.1 sound setup about 4-5 years ago but I have been using headphones exclusively since.
I have tried deleting the .ini file to reset all config options but that did not fix the issue.

What additional information can I give to help solve this issue?
User avatar
Chris
Posts: 2945
Joined: Thu Jul 17, 2003 12:07 am
Graphics Processor: ATI/AMD with Vulkan/Metal Support

Re: No sound from behind

Post by Chris »

Evil Space Tomato wrote: Sun Jan 28, 2024 2:38 pm I get no sound from behind me, this occurs in zdoom and its child ports (gzdoom, skulltag, zandronum).
Left and right channels work just fine but once a sound start closer to directly behind me it quickly fades to 0% volume
However in DSDA doom I can hear stuff from behind me.
I used to have a 5.1 sound setup about 4-5 years ago but I have been using headphones exclusively since.
Make sure your audio device is configured for stereo or headphones in the system settings. If the device is still configured for surround sound, sounds from behind will try to use the rear/surround speakers, but if all you have connected is headphones those speakers won't be heard. Same for anything that tries to use the front-center speaker. I wager any surround sound content you try to play has the same issue (if the app isn't configured to force a stereo downmix, at least), anything that's supposed to play from the rear/surround or front-center speakers are just left silent.
Evil Space Tomato
Posts: 78
Joined: Tue Jul 20, 2004 7:56 pm
Graphics Processor: nVidia with Vulkan support

Re: No sound from behind

Post by Evil Space Tomato »

Ah thanks for the info, just in case any one else runs into this problem here is a step by step guide for windows.

1. Open control panel
2. Open Sound
3. Scroll down on the playback tab to find "Speakers"
4. Select "Speakers" and Click configure
5. Switch to Stereo
6. Click next then finish
7. Run GZdoom to confirm it worked

[imgur]https://imgur.com/a/nE32YQh[/imgur]
User avatar
Jekyll Grim Payne
 
 
Posts: 1078
Joined: Mon Jul 21, 2008 4:08 am
Preferred Pronouns: He/Him
Graphics Processor: nVidia (Modern GZDoom)

Re: No sound from behind

Post by Jekyll Grim Payne »

Evil Space Tomato wrote: Sun Jan 28, 2024 5:34 pm [imgur]https://imgur.com/a/nE32YQh[/imgur]
FYI, for imgur tags to work you need to link a specific image, not an album. By default imgur opens an album for you (you can easily see that by noticing there's an "/a/" in the URL). To make them work, click the "..." button at the top right of the image and click "Copy link" to get the embeddable URL:

Code: Select all

[imgur]https://imgur.com/0WagjcK[/imgur]
Result:

Return to “Technical Issues”