Weird pixel rotation

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE/EDuke32/Raze? Did your computer break? Ask here.

Moderator: GZDoom Developers

Forum rules
Contrary to popular belief, we are not all-knowing-all-seeing magical beings!

If you want help you're going to have to provide lots of info. Like what is your hardware, what is your operating system, what version of GZDoom/LZDoom/whatever you're using, what mods you're loading, how you're loading it, what you've already tried for fixing the problem, and anything else that is even remotely relevant to the problem.

We can't magically figure out what it is if you're going to be vague, and if we feel like you're just wasting our time with guessing games we will act like that's what you're really doing and won't help you.
User avatar
Marrub
 
 
Posts: 1195
Joined: Tue Feb 26, 2013 2:48 pm
Preferred Pronouns: No Preference
Operating System Version (Optional): Arch Linux
Graphics Processor: ATI/AMD with Vulkan/Metal Support

Weird pixel rotation

Post by Marrub »

I don't really know what kind of issue this is. For a long while now, my mod's HUD has had a slight bent to it. I tried to pinpoint it using screenshots saved in my config folder, and it seems some time between 2022-09 (first screenshot) and 2023-03 (second), something changed. My hardware and OS haven't changed at all, besides updating drivers.
ImageImage
The quit message menu always bends. This also happens in any menus with clean scaling disabled, but not ones with it enabled.
You may need to zoom in to these images a bit to see it.
ImageImage
It also happens in some other mods, like DRLA.
Image
However, some mods don't have this, like DRadys.
Image
What's going on here?
EDIT: I forgot one thing. The pixels... realign... when using normalNx texture upscaling and trilinear filtering.
Image
It looks really weird, though, because this is an accursed setup.
EDIT 2: Here's all my video settings.
Spoiler:
Also, for added context:
  • No one else has been able to replicate this to my knowledge.
  • My specific GPU is an AMD Radeon RX590, and here's the lspci info:

    Code: Select all

    05:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] [1002:67df] (rev e1) (prog-if 00 [VGA controller])
            Subsystem: Sapphire Technology Limited Nitro+ Radeon RX 570/580/590 [1da2:e366]
            Physical Slot: 2
            Flags: bus master, fast devsel, latency 0, IRQ 41
            Memory at d0000000 (64-bit, prefetchable) [size=256M]
            Memory at e0000000 (64-bit, prefetchable) [size=2M]
            I/O ports at c000 [size=256]
            Memory at efd00000 (32-bit, non-prefetchable) [size=256K]
            Expansion ROM at 000c0000 [disabled] [size=128K]
            Capabilities: <access denied>
            Kernel driver in use: amdgpu
            Kernel modules: amdgpu
    
  • This occurs regardless of OS. I've tested on both Arch Linux and Windows 10.
  • This occurs regardless of renderer API or render mode.
  • On Linux, setting the API to OpenGL (but not OpenGL ES) crashes the game during loading. I don't know why this is and I don't think it's even a "reportable" issue. It's not a problem for me because I always use Vulkan.
EDIT³: I ran it in a debugger to try and see why OpenGL is crashing.

Code: Select all

(gdb) bt
#0  0x00007ffff6f2c73d in syscall () from /usr/lib/libc.so.6
#1  0x00007fffe89128de in ?? () from /usr/lib/dri/radeonsi_dri.so
#2  0x00007fffe89352fb in ?? () from /usr/lib/dri/radeonsi_dri.so
#3  0x00007fffe8a5f759 in ?? () from /usr/lib/dri/radeonsi_dri.so
#4  0x0000555555b49d57 in OpenGLRenderer::FShader::Load (
    this=this@entry=0x55555e6e4a90,
    name=name@entry=0x555555e43a47 "Basic Fuzz",
    vert_prog_lump=0x555555e16f75 "shaders/glsl/main.vp",
    frag_prog_lump=0x555555e16f8a "shaders/glsl/main.fp",
    proc_prog_lump=proc_prog_lump@entry=0x555555e43a52 "shaders/glsl/fuzz_standard.fp",
    light_fragprog=light_fragprog@entry=0x555555e43881 "shaders/glsl/material_normal.fp", defines=0x555557351f5c "")
That doesn't look good.
User avatar
InsanityBringer
Posts: 3386
Joined: Thu Jul 05, 2007 4:53 pm
Location: opening the forbidden box

Re: Weird pixel rotation

Post by InsanityBringer »

I've seen this issue too on basically every AMD card I've tried. It's present currently on a AMD Radeon RX 7800 XT, it was present on my RX 580, on my R7 260x, and was probably present on earlier cards. I always just assumed it was a problem AMD GPUs had and not anything specific to GZDoom since I remember seeing it on emulators and other things.. but now I run those crusty old emulators and I don't see it.. hmm.

Here's it happening at 1080p. At 4k I guess there's enough pixels that it finds something that gives correct results.
Image

Return to “Technical Issues”