[Fixed] 2.0.50 doesn't like my WADs :-(

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.
User avatar
Posts: 26537
Joined: Tue Jul 15, 2003 4:58 pm
Location: Scotland

2.0.50 doesn't like my WADs :-(

Post by Enjay »

Something has changed between 48 and 50 (didn't get a chance to try 49). 2.0.50 can load my Aspects IWAD and I get as far as the titlepic. If I try and start a game, Zdoom just drops me back to the desktop with no message. This did not happen with 2.0.48. It is something to do with map01, but only happens when loading using the IWAD. If I export map01 and load it on top of doom2.wad, it works (but without textures etc, obviously). If I warp to another map in Aspects, so far, all of these have been OK.

This is a map I have been using for ages, with resources I have been using for ages and it has worked with Zdoom versions since relatively low 1.23 beta numbers.

I've copied a console output below from a game startup, but see nothing in it to indicate what could have gone wrong. Sorry, that's all I have to go on.

Code: Select all

Log started: Sun Oct 26 20:33:58 2003

 adding zdoom.wad (123 lumps)
 adding c:/progra~1/aspects/bgpa1.wad (12383 lumps)
 adding C:/Doom/zdoom2/skins/bba.wad (68 lumps)
 adding C:/Doom/zdoom2/skins/Blud.wad (52 lumps)
 adding C:/Doom/zdoom2/skins/NJBLK01.wad (344 lumps)
 adding C:/Doom/zdoom2/skins/njsplash.WAD (141 lumps)
 adding C:/Doom/zdoom2/skins/scope.wad (2 lumps)
 adding C:/Doom/zdoom2/skins/Variants.wad (364 lumps)
 adding C:/Doom/zdoom2/skins/Xhairs.wad (32 lumps)
CPU Speed: 2813.549788 MHz
CPU Vendor ID: GenuineIntel
  Name: Intel(R) Pentium(R) 4 CPU 2.80GHz 4 CPU 2.80GHz
  Family 15, Model 2, Stepping 7
  Features: MMX SSE SSE2
I_InitSound: Initializing FMOD
  Setting DirectSound output succeeded
  Setting driver 0 succeeded
  Initialization succeeded
Resolution: 800 x 600
Patch installed
Aspects Resources
Game Start Up
84 Levels
Loads of music
More fun than you can shake a daystick at
Init miscellaneous info.
Init DOOM refresh subsystem.
Init Playloop state.
Setting up sound.
Checking network game status.
player 1 of 1 (1 nodes)
Init status bar.

Also, in Aspects and Marine Assault (which use the same palette) black colours on textures are being shown as a sort of tan/brown colour. Easiest way to see this is to load up Marine Assault. The briefing screen right at the start should be surrounded by a black texture, but it is the brown colour I mentioned. The same goes for loads of textures and other graphics throughout the level. You can also see it on the titlepic, but only when viewed as the console background - when viewd normally (as the intro title) it looks OK.

You can see similar effects with the RTC-3057 demo and Fredriks fughdm01.wad - both of which use very similar palettes.
User avatar
Posts: 1152
Joined: Tue Jul 15, 2003 9:08 pm

Post by Ultraviolet »

I have a "nightvision" alias set up, and when I use it and then reset everything back to normal, everything in Marine Assault looks fine again.
User avatar
Posts: 26537
Joined: Tue Jul 15, 2003 4:58 pm
Location: Scotland

Post by Enjay »

Just so people know, Randy has fixed the palette problem (as the location of this thread would now indicate) and has identified what the problem was with the levels that just dropped zdoom to the desktop without any message.

The problem for the insta-quit bug was related to a fake music lump. For years, I've been using a fake music lump (a simple text lump) that I use in scripts if I want to make the music silent using the setmusic command. It's so long since I set it up, that I'd actually forgotten that this lump was not really a music lump. On 2 maps it was set as the music for the level in mapinfo, so that these maps would start silent, and then change to have music later on via scripting (yes, I know it can be done other ways). This has worked OK for a year or maybe even two. However, there is something about the latest FMOD that will crash Zdoom if it encounters an unrecognised file format - and there is the problem. Randy has e-mailed the bug to the FMOD people, and the easy fix for my maps is to use a genuine silent music lump instead of a fake one.

However, I thought it was worth mentioning because I know a few people have used the same method to create a fake silent music lump.
User avatar
Site Admin
Posts: 7746
Joined: Wed Jul 09, 2003 10:30 pm

Post by randi »

And it will be fixed in the next fmod.dll. Specifically, it only applies when trying to load small songs from the middle of a file (such as the case when loading a song from a wad). But I don't even need to wait for the next fmod; I can just treat anything too small as not a song if it hasn't already been identified by the time I ask fmod if it can handle it.

Return to “Closed Bugs [GZDoom]”