Ogg OPUS music does not play in full

Post bugs that have to do with sound and/or in-game music here.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!
User avatar
generic name guy
Posts: 122
Joined: Wed Nov 11, 2020 3:25 pm
Graphics Processor: nVidia with Vulkan support
Location: Brazil

Ogg OPUS music does not play in full

Post by generic name guy »

In GZDoom 4.11.3, music in .opus format does not play past 12-16 seconds or so. To reproduce this, you only have to convert any song that is around 1 minute long into OPUS and try to play it in GZDoom.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 49073
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Ogg OPUS music does not play in full

Post by Graf Zahl »

It's a known issue, the 4.11.3 package was shipped with the wrong libsndfile.dll, please take the one from the 4.11.2 package and copy it over the old one.
User avatar
generic name guy
Posts: 122
Joined: Wed Nov 11, 2020 3:25 pm
Graphics Processor: nVidia with Vulkan support
Location: Brazil

Re: Ogg OPUS music does not play in full

Post by generic name guy »

This has been happening since August, so around 4.9 or so, not 4.11.

Return to “Audio/Music Bugs”