The official "ZDoom on Linux" thread.

Handy guides on how to do things, written by users for users.

Moderators: GZDoom Developers, Raze Developers

Forum rules
Please don't start threads here asking for help. This forum is not for requesting guides, only for posting them. If you need help, the Editing forum is for you.
Posts: 143
Joined: Fri Nov 15, 2019 4:28 am
Graphics Processor: Intel with Vulkan/Metal Support
Location: Australia

Re: The official "ZDoom on Linux" thread.

Post by bLUEbYTE »

KynikossDragonn wrote:
bLUEbYTE wrote:Here's a tip for Linux users who have recent Intel iGPUs (Skylake+ I think) and with recent version of MESA (20+).

What happened is that with the latest Mesa drivers they switched to a new opengl driver backend called 'iris', from 'i965'. While this seems to have boosted performance in other workloads, in GZDoom and LZDoom I verified that this actually has a significant hit to FPS.
I'd like to report that, I'm running on a Intel Iris Pro 580 for graphics and I don't get any performance loss using iris_dri rather than i965_dri. I'm currently on Mesa 20.2.3, judging by the name of the library itself I think the new iris_dri is geared towards Iris and Iris Pro graphics and not just the "Intel UHD" graphics family. I could be wrong though. I haven't run into anything other than maybe Blender that I need to manually override the driver to i915.

I even get 60 FPS in Total Chaos. Though it stutters a lot because Mesa's shader compiler is really slow apparently...

I hope it's okay to post this here to let other people know of my experiences with Intel graphics on Linux in regards to GZDoom.
In my case there's a definitive difference between the two. GPU is Iris Plus 655 on Kubuntu 20.04.1. GZDoom is configured with dynamic lights, 1080p in OpenGL mode (Vulkan is slightly slower).

FPS figures at the start scene of the map:
wine gzdoom.exe +vid_fps 1 +map map13 : 23 FPS
MESA_LOADER_DRIVER_OVERRIDE=i965 wine gzdoom.exe +vid_fps 1 +map map13 : 45FPS

I had observed a similar difference in native linux version as well, but I'm running the windows binary through wine because gamepad support in Linux is inferior.
User avatar
Posts: 19
Joined: Wed May 06, 2020 8:34 am
Graphics Processor: nVidia (Modern GZDoom)
Location: Argentina

A launcher/frontend for snap GZDoom?

Post by Nimlouth »

Hey all, recently hopped into Manjaro (which is an Arch based distro, btw) and started adventuring into LinuxGZDoom. I tried installing GZDoom from the AUR but it just wouldn't run propperly. So now I'm now using a snap and, though it works flawlessly (way better than when I was on windows actually), I'm also currently lacking a proper frontend/launcher. I mod my GZDoom HEAVILY, since I use lots of little HuD, music, QoL and misc addons. So editing GZDoom's shortcut each time I want to have a different load order is a bit cumbersome, not even mentioning that it requires me to have all my files in the same folder where the iwads are located, making my mod collection a nightmare to sort.

I tried twad and It just doesn't work somehow (a shame because it's a super cool terminal frontend), neither does qzdl. I'm in the dark, does anybody knows a frontend/launcher that does work for managing 20+ files load orders? thx in advance.

User avatar
Posts: 321
Joined: Mon Feb 12, 2018 12:26 am
Graphics Processor: Intel (Legacy GZDoom)
Location: Australia

Re: The official "ZDoom on Linux" thread.

Post by fakemai »

Try DoomRunner. It's what I use after getting sick of Bash aliasing and might work out pretty well for you. It works on a preset system but makes it easy to choose the IWAD/mapset/engine/INI and you can also uncheck mods in a given preset, as for example you might to enable different monster packs with a weapon mod, or the ones required for Wrath of Cronos with different IWADs. Also if you haven't, look at auto-loading since that works better to mods you may want universally (Episodic-EX and such) and can be turned off with a command switch, something that presets can also have if necessary.
Posts: 413
Joined: Fri Aug 03, 2012 6:44 am

Re: The official "ZDoom on Linux" thread.

Post by invictius »

Trying to get 1.8.2 working on latest i386 lubuntu. It won't install, I get "dependency is not satisfiable - libflac++6 (>1.2.1-1.2)

Return to “Tutorials”