Fire animation halt

Moderator: Raze Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.
Guest

Fire animation halt

Post by Guest »

Latest raze-x64-1.4pre-35-ga94f29860 and earlier
Duke3d.grp 1.3d from cd; md5 981125CB9237C19AA023719958D2B50

On the 1st level of DN the fire animations in a dumbster box stop after 50-60 seconds from the level start. One flame will restart after few seconds, the other one has some random factor in it's timing(?); it'll restart 5-40 seconds later.

Save game: https://www.dropbox.com/s/h55rxwbh13om72p/Save.7z?dl=1
The flames will stop a few seconds from the save game load.
User avatar
mjr4077au
Posts: 720
Joined: Sun Jun 16, 2019 9:17 pm
Discord: mjr4077au#1027
Github ID: mjr4077au
Graphics Processor: nVidia with Vulkan support
Location: Gosford NSW, Australia

Re: Fire animation halt

Post by mjr4077au »

There's some issue with the older scripts in 1.3D that are causing this. It doesn't happen with 1.5. I recommend you get a 1.5 (Atomic) group file and use that instead.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48040
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Fire animation halt

Post by Graf Zahl »

There things aren't really fixable anyway due to being defined by scripts outside the engine. Due to CON's lack of structure and polish there's quite a few things that are broken in Duke and extremely hard to repair.

In NAM, for example, there is one script that can actually run into an endless loop spawning ever more new stuff until the engine crashes.

Return to “Closed Bugs”