[1.3.1][SW] Shadow Ninja Projectiles Behaving improperly

Moderator: Raze Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.
GunPuncher
Posts: 3
Joined: Sun Dec 19, 2021 4:02 pm
Graphics Processor: nVidia (Modern GZDoom)

[1.3.1][SW] Shadow Ninja Projectiles Behaving improperly

Post by GunPuncher »

Making this Post with an actual account because I've needed to make one anyways as much as I've been using ZDoom derivitaves:

Anyways, I was enjoying your fine work on Raze, and I updated to 1.3, and noticed that the Shadow Ninja Projectiles aren't working properly at all. I dunno why or how, but in 1.2 something which was the last version I had, they worked fine. The Single fireball that shoots flames to the side has collision, but the flames don't, and neither of them do any damage. Also the flames stick to the walls and don't despawn. The other flamewall also seems to do self damage to the Ninja, which is something I don't remember being a thing in the original game or the source ports I've used. Bit of an issue that. They're a pain, but I enjoy pain, so losing that it a bit of an issue, yeah?

User avatar
mjr4077au
Posts: 733
Joined: Sun Jun 16, 2019 9:17 pm
Graphics Processor: nVidia with Vulkan support
Location: Gosford NSW, Australia

Re: [1.3.1][SW] Shadow Ninja Projectiles Behaving improperly

Post by mjr4077au »

This should be fixed in master. Could I trouble you to please try a dev build from https://devbuilds.drdteam.org/raze/?
GunPuncher
Posts: 3
Joined: Sun Dec 19, 2021 4:02 pm
Graphics Processor: nVidia (Modern GZDoom)

Re: [1.3.1][SW] Shadow Ninja Projectiles Behaving improperly

Post by GunPuncher »

No Worries m8. Picked the very most recent build, and the behavior seems much more normal. The central orb still doesn't do damage, but I just checked VoidSW and Classic Redux, so I guess that orb never did damage in the first place. Huh, go figure. The Shadow Ninja definitely doesn't take self damage from his attacks though, and that's still in the build. I don't know if that's a flag that has to be set or whatnot, but that's still there. Nothing game-breaking, but worth nothing. Thanks for the help!
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48043
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: [1.3.1][SW] Shadow Ninja Projectiles Behaving improperly

Post by Graf Zahl »

This was already fixed on an internal report from our testers.
Regarding the rest of what you mentioned, if other ports replicate it, it is intended.
The bug here was a single mistaken '==' for a '!=' which solely affected this single projectile.

Return to “Closed Bugs”