software mode

Moderator: Raze Developers

User avatar
Rachael
Admin
Posts: 13084
Joined: Tue Jan 13, 2004 1:31 pm
Preferred Pronouns: She/Her

Re: software mode

Post by Rachael »

Whilst I sympathize with your GPU problem, there's literally nothing I or anyone can do about that. You can't just wish a software renderer into existence within a day. It doesn't work that way.

I re-enabled softpoly in Raze with an experimental build and it crashed literally within 10 seconds of play, even with the new renderer.

I also tried Vulkan emulated with Swiftshader, and while it worked without crashing, FPS was way too low to be considered even remotely playable - and that was on my hexa-core Ryzen 5. And I am sure it would be a lot worse on a system that needs a new GPU.

Sorry but there's nothing we can do. You won't be happy with either solution, Raze just either is not stable enough or does not perform well.
User avatar
sinisterseed
Posts: 1335
Joined: Tue Nov 05, 2019 6:48 am
Preferred Pronouns: He/Him
Graphics Processor: nVidia with Vulkan support

Re: software mode

Post by sinisterseed »

Rachael wrote:I re-enabled softpoly in Raze with an experimental build and it crashed literally within 10 seconds of play, even with the new renderer.
It always will, as well.

As far as I remember, SoftPoly essentially needs a rework in order to work with Build, which is why it was quickly dropped after a fast test before 0.7. And that effort is simply better spent elsewhere, too.

Return to “Closed Feature Suggestions [Raze]”