How to disable on-screen keyboard in save menu?

Discuss anything ZDoom-related that doesn't fall into one of the other categories.

How to disable on-screen keyboard in save menu?

Postby bebipbop » Fri Jul 19, 2019 4:22 pm

https://i.imgur.com/bzzC9dR.png
How do I disable this keyboard? It's very annoying.

edit: to clarify, I know you can avoid it by pressing enter rather than clicking on it. I want to be able to click on it without the OSK coming up.
bebipbop
 
Joined: 13 May 2019
Discord: Silquetoast#7693
Twitch ID: Silquetoast
Github ID: Silquetoast
Operating System: Windows 10/8.1/8 64-bit
Graphics Processor: nVidia with Vulkan support

Re: How to disable on-screen keyboard in save menu?

Postby MFG38 » Sun Jul 21, 2019 6:31 am

To my knowledge, the only way to disable that is by disabling the mouse in menus (m_use_mouse 0), unless you use the "press Enter" workaround.
User avatar
MFG38
 
Joined: 14 Apr 2019
Location: Finland
Operating System: Windows 10/8.1/8 64-bit

Re: How to disable on-screen keyboard in save menu?

Postby _mental_ » Sun Jul 21, 2019 7:51 am

Set m_showinputgrid CVAR to -1.
_mental_
 
 
 
Joined: 07 Aug 2011

Re: How to disable on-screen keyboard in save menu?

Postby Enjay » Sun Jul 21, 2019 8:27 am

MFG38 wrote:To my knowledge, the only way to disable that is by disabling the mouse in menus (m_use_mouse 0), unless you use the "press Enter" workaround.

That's certainly not required. My mouse is not disabled in the menus and I didn't even realise that keyboard existed. :shock:
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Re: How to disable on-screen keyboard in save menu?

Postby MFG38 » Mon Jul 22, 2019 7:00 am

Enjay wrote:
MFG38 wrote:To my knowledge, the only way to disable that is by disabling the mouse in menus (m_use_mouse 0), unless you use the "press Enter" workaround.

That's certainly not required. My mouse is not disabled in the menus and I didn't even realise that keyboard existed. :shock:


I stand corrected in that case.
User avatar
MFG38
 
Joined: 14 Apr 2019
Location: Finland
Operating System: Windows 10/8.1/8 64-bit

Re: How to disable on-screen keyboard in save menu?

Postby Xeotroid » Mon Jul 22, 2019 5:01 pm

It might be a good idea to update the wiki entry on it, then. If three values for it are accepted, it shouldn't even be noted as boolean.
User avatar
Xeotroid
 
Joined: 23 Jun 2012
Location: Czech Rep.

Re: How to disable on-screen keyboard in save menu?

Postby bebipbop » Tue Jul 23, 2019 6:13 am

Thanks for the help, guys :)
bebipbop
 
Joined: 13 May 2019
Discord: Silquetoast#7693
Twitch ID: Silquetoast
Github ID: Silquetoast
Operating System: Windows 10/8.1/8 64-bit
Graphics Processor: nVidia with Vulkan support

Re: How to disable on-screen keyboard in save menu?

Postby Enjay » Tue Jul 23, 2019 7:08 am

I just started GZDoom and typed m_noinputgrid at the console. It reported the value as 0. I changed it to 1 and got the grid. I changed to back to 0 and no longer got the grid. I also tried -1 and still no grid. I am wondering why is -1 recommended?
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Re: How to disable on-screen keyboard in save menu?

Postby _mental_ » Tue Jul 23, 2019 8:56 am

You need to use mouse or controller to get the grid when CVAR is zero. -1 disables it completely.
_mental_
 
 
 
Joined: 07 Aug 2011

Re: How to disable on-screen keyboard in save menu?

Postby Enjay » Tue Jul 23, 2019 9:23 am

Ah, right, I see it now. With it set at 0, if I actually use the mouse to click on the save name, the keyboard pops up. If I just do it using the enter key, the keyboard does not pop up (even though I could have used the mouse if I'd wanted, and thereby have gotten the keyboard). -1 does indeed stop it entirely.
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Re: How to disable on-screen keyboard in save menu?

Postby Graf Zahl » Tue Jul 23, 2019 1:09 pm

I think the documentation is older than the 'completely off' option. With the old menu code there was no mouse so there was no need to switch this off with the mouse enabled.
User avatar
Graf Zahl
Lead GZDoom Developer
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: How to disable on-screen keyboard in save menu?

Postby Blue Shadow » Thu Jul 25, 2019 1:27 pm

Trying to update the wiki, is this correct for the various modes?
  • -1 - Disables the display of the grid.
  • 0 - Displays the grid only if a controller, such as a mouse or gamepad, is used.
  • 1 - Always displays the grid.
User avatar
Blue Shadow
 
 
 
Joined: 14 Nov 2010
Operating System: Windows 10/8.1/8 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: How to disable on-screen keyboard in save menu?

Postby _mental_ » Thu Jul 25, 2019 1:33 pm

Yes, just one or greater in the last case.
_mental_
 
 
 
Joined: 07 Aug 2011

Re: How to disable on-screen keyboard in save menu?

Postby Blue Shadow » Thu Jul 25, 2019 1:51 pm

Thanks. Wiki updated.
User avatar
Blue Shadow
 
 
 
Joined: 14 Nov 2010
Operating System: Windows 10/8.1/8 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: How to disable on-screen keyboard in save menu?

Postby Graf Zahl » Thu Jul 25, 2019 2:38 pm

For 0 is should read 'enable only', not 'disable only'.
User avatar
Graf Zahl
Lead GZDoom Developer
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Next

Return to General

Who is online

Users browsing this forum: MSN [Bot], Semrush [Bot] and 3 guests