3.4.1 PITCHFROMMOMENTUM and speed 0

Is there something that doesn't work right in the latest GZDoom? Post about it here.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

3.4.1 PITCHFROMMOMENTUM and speed 0

Postby Enjay » Sun Jul 29, 2018 7:14 pm

This affects all versions I think. It's also probably not a bug and more a case of "well, how is GZDoom supposed to know what to do when speed is 0" but, just in case...

Setting things up like this:

  • a projectile set up to use a model
  • use the PITCHFROMMOMENTUM flag in MODELDEF
  • spawn the projectile (using SpawnProjectile in ACS)
  • set the parameters so that the projectile is moving straight down - i.e. a speed of 0 and a negative vertical speed

Result: the model points upwards even though it is travelling downwards.
Giving it a speed of 1 makes it point downwards.

Map attached. The first 3 switches (from left to right) will spawn a downwards projectile (v speed -64). The last 2 spawn a projectile upwards (v speed 64). The scripts responsible print the forward speed values. The left-most switch exhibits the kind of behaviour that I'm talking about.
Attachments
testrocket.pk3
(146.71 KiB) Downloaded 31 times
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Return to Bugs

Who is online

Users browsing this forum: No registered users and 0 guests