Large Custom OGGs "skipping"

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.
Volasaurus
Posts: 5
Joined: Tue Mar 03, 2020 2:07 am
Discord: 🦖Volasaurus#0260
Graphics Processor: nVidia with Vulkan support

Large Custom OGGs "skipping"

Post by Volasaurus »

Description:
When playing with custom oggs, occasionally they'll "skip" like an old CD-player. It's consistently around the same length every time, but this length varies from session to session. Before importing these oggs and after exporting them with slade, they sound fine, but in-game the skipping occurs. This doesn't happen to every ogg. As far as I can tell, this is only happening with OGGs larger than 4 MB.

Priority: Eh? Not high, but there could be something more insidious causing it?

Steps to Reproduce:
1. Open GZDoom with a resource that has custom OGGs larger than 4 MB.
2. Play as normal, but stay in a level long enough to let the music finish at least once.
User avatar
Chris
Posts: 2841
Joined: Thu Jul 17, 2003 12:07 am
Graphics Processor: ATI/AMD with Vulkan Support

Re: Large Custom OGGs "skipping"

Post by Chris »

Does it only happen after looping? Is music affected, or sound effects, or both? "Oggs larger than 4 MB" is a bit vague, and I tested with an 8.4MB Ogg without any noticeable problem after looping. Do you have a specific file exhibiting the problem?
User avatar
SanyaWaffles
Posts: 764
Joined: Thu Apr 25, 2013 12:21 pm
Discord: SanyaWaffles#0950
Twitch ID: sanyawaffles
Graphics Processor: nVidia with Vulkan support
Location: Disappointment Island

Re: Large Custom OGGs "skipping"

Post by SanyaWaffles »

I've not noticed any lagging with large OGGs on my end and we use loop points extensively.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 47995
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Large Custom OGGs "skipping"

Post by Graf Zahl »

I also never experienced this kind of thing with recent code. A long time ago there was a problem like this when looping MP3's but that was due to a bug in the decoder library that could be worked around. What GZDoom version are you using?
Volasaurus
Posts: 5
Joined: Tue Mar 03, 2020 2:07 am
Discord: 🦖Volasaurus#0260
Graphics Processor: nVidia with Vulkan support

Re: Large Custom OGGs "skipping"

Post by Volasaurus »

To answer your questions:

It happens the first time it plays, and it only happens with music. Two specific tracks seem to do this, but none of the rest of the tracks in the wad exhibit this behavior. In addition, while played in SLADE and while played outside of the game, these oggs play back normally.

I'm using GZdoom 4.5.0.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 47995
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Large Custom OGGs "skipping"

Post by Graf Zahl »

So, what tracks? Can you post a link?
And what's your system's specs, e.g. CPU type, how many cores, SSD or HDD?
Volasaurus
Posts: 5
Joined: Tue Mar 03, 2020 2:07 am
Discord: 🦖Volasaurus#0260
Graphics Processor: nVidia with Vulkan support

Re: Large Custom OGGs "skipping"

Post by Volasaurus »

https://drive.google.com/file/d/1OLZgRV ... sp=sharing

https://drive.google.com/file/d/1QhZv8O ... sp=sharing

CPU: AMD Ryzen 5 1600 (12 threads on 6 cores)
GPU: EVGA Nvidia GeForce 1060 6GB
RAM: 64 GB @ 1066 MHz (lol, I know)
Relevant SSD: 55 GB Patriot Blaze
User avatar
SanyaWaffles
Posts: 764
Joined: Thu Apr 25, 2013 12:21 pm
Discord: SanyaWaffles#0950
Twitch ID: sanyawaffles
Graphics Processor: nVidia with Vulkan support
Location: Disappointment Island

Re: Large Custom OGGs "skipping"

Post by SanyaWaffles »

I have a question. Does your audio files have looping points?

Return to “Closed Bugs”