[Not ZDoom] fmod "Starting MIDI playback failed" problem

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

fmod "Starting MIDI playback failed" problem

Postby doom-guy » Tue Mar 22, 2011 7:59 pm

I followed the instructions from http://zdoom.org/wiki/Compile_ZDoom_on_Linux on fedora 14 and I played the game with my wads but I can't hear the music and I saw this in the console: Starting MIDI playback failed
How do I fix this?
doom-guy
 
Joined: 23 Mar 2011

Re: fmod "Starting MIDI playback failed" problem

Postby Edward-san » Wed Mar 23, 2011 12:54 am

Try changing the 'output system' and the 'midi device' options in: "menu->options->sound options" as you like. See what happens.
Edward-san
Mathematics is the language with which God has written the universe. (Galilei)
 
Joined: 17 Oct 2009

Re: fmod "Starting MIDI playback failed" problem

Postby doom-guy » Wed Mar 23, 2011 2:58 pm

Timidity++ and opl synth devices work.
But fmod doesn't work. I tried all output systems but I saw the same error.
doom-guy
 
Joined: 23 Mar 2011

Re: fmod "Starting MIDI playback failed" problem

Postby Graf Zahl » Wed Mar 23, 2011 3:47 pm

FMod requires a DLS file as sound font which does not come normally with Linux. This sounds to me that it simply was not configured.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: fmod "Starting MIDI playback failed" problem

Postby doom-guy » Wed Mar 23, 2011 5:17 pm

Where do I get fmod sound fonts for linux?
How do I have to configure fmod?
doom-guy
 
Joined: 23 Mar 2011

Re: fmod "Starting MIDI playback failed" problem

Postby Gez » Wed Mar 23, 2011 6:05 pm

Wiki: FMOD.
Gez
 
 
 
Joined: 06 Jul 2007

Re: fmod "Starting MIDI playback failed" problem

Postby doom-guy » Wed Mar 23, 2011 6:56 pm

I found information about fmod but I didn't find a download link about the fmod sound fonts for linux.
Can you give me a link?
doom-guy
 
Joined: 23 Mar 2011

Re: fmod "Starting MIDI playback failed" problem

Postby Gez » Thu Mar 24, 2011 1:31 pm

Gez
 
 
 
Joined: 06 Jul 2007

Re: fmod "Starting MIDI playback failed" problem

Postby Edward-san » Thu Mar 24, 2011 4:07 pm

I've done this search:
"dls file fmod linux"
on google, but nothing interesting appeared, actually (check out the first link, lol).
Edward-san
Mathematics is the language with which God has written the universe. (Galilei)
 
Joined: 17 Oct 2009

Re: fmod "Starting MIDI playback failed" problem

Postby Bio Hazard » Thu Mar 24, 2011 4:13 pm

If you want midi support, just use FluidSynth and one of the bajillion sf2 soundfonts out there. (Some distributions have a "fluid-soundfont" package that works without even configuring anything.) Easy.
User avatar
Bio Hazard
Lord of the Lord of Nitpicking.
 
Joined: 16 Aug 2003
Location: ferret ~/C/ZDL $

Re: fmod "Starting MIDI playback failed" problem

Postby Gez » Thu Mar 24, 2011 4:35 pm

Edward-san wrote:I've done this search:
"dls file fmod linux"

Try this one.
Gez
 
 
 
Joined: 06 Jul 2007

Re: fmod "Starting MIDI playback failed" problem

Postby Edward-san » Thu Mar 24, 2011 5:59 pm

Oh, good indeed.
I wish I could find a download link which isn't in a file sharing site (in order to copy-paste the link to wiki page). :/
Edward-san
Mathematics is the language with which God has written the universe. (Galilei)
 
Joined: 17 Oct 2009

Re: fmod "Starting MIDI playback failed" problem

Postby doom-guy » Thu Mar 24, 2011 8:39 pm

Gez wrote:
Edward-san wrote:I've done this search:
"dls file fmod linux"

Try this one.

Thanks for the gm.dls file :D
I can use fmod sound now.
doom-guy
 
Joined: 23 Mar 2011


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 2 guests