Old boring stuff

Discuss anything ZDoom-related that doesn't fall into one of the other categories.
Anonymous

Old boring stuff

Post by Anonymous »

This is a basic question I know but I've lost info after a hardrive crash and have not used Zdoom for a while:

How do I make the run/walk switch work? I've turned off 'always run' and have remembered enough to make joyspeedmultiplier=0.5, so now I'm always walking. what do I put in the cfg file to make +speed modify this value? +speed is bound to a joypad button
User avatar
HotWax
Posts: 10002
Joined: Fri Jul 18, 2003 6:18 pm
Location: Idaho Falls, ID

Post by HotWax »

alias +runon "joyspeedmultiplier=1.0"
alias -runon "joyspeedmultiplier=0.5"
bind JOY1 +runon

That should do roughly what you want it to. Season the values to taste. I don't use a joystick so don't exactly know what you're asking. Hope that helps.
Anonymous

Post by Anonymous »

I was using zdoom 1.22 and have solved this by moving to zdoom 2. I find that the run/walk actions happen the opposite way round to what i expect though ie normally run - walk when pressed.

I have found that the strafe function doesn't work properly - I turn at the same time as moving sideways. How would I stop this?

Is it ok to discuss Doom III in this forum?

Jakell.
User avatar
HotWax
Posts: 10002
Joined: Fri Jul 18, 2003 6:18 pm
Location: Idaho Falls, ID

Post by HotWax »

jakell wrote:I was using zdoom 1.22 and have solved this by moving to zdoom 2. I find that the run/walk actions happen the opposite way round to what i expect though ie normally run - walk when pressed.
Make sure autorun is turned off -- it reverses the behavior of +speed.
I have found that the strafe function doesn't work properly - I turn at the same time as moving sideways. How would I stop this?
Not sure, sorry. :?
Is it ok to discuss Doom III in this forum?
As long as you keep it in General nobody should complain.

Return to “General”