[Fixed] [Duke3D] Failure to apply translation to keycards.

Moderator: Raze Developers

[Duke3D] Failure to apply translation to keycards.

Postby Dynamo » Fri Apr 23, 2021 1:58 am

As mentioned in the Discord server, I noticed that player-held keycards do not show up with the correct translation when used.

Here is how it looks (correctly) in RedNukem: https://cdn.discordapp.com/attachments/ ... nknown.png

And here is how it looks currently in Raze: https://cdn.discordapp.com/attachments/ ... nknown.png

(to note, this is not related to the new renderer, as it behaves the same way in Polymost too)

I tested this on Red Light District, which also has a yellow keycard, and the same problem applies to that one as well. It is also possible to have custom keycard colors in some usermaps (New L.A. in Last Reaction comes to mind if I'm not mistaken) so I imagine it is buggy even in those situations.
User avatar
Dynamo
It's a jungle out there.
 
Joined: 07 Jun 2008
Location: Lygon Street, Carlton

Re: [Duke3D] Failure to apply translation to keycards.

Postby Graf Zahl » Fri Apr 23, 2021 11:39 am

Fixed. Some recent refactoring tried to unify the palette handling for HUD sprites but totally missed the fact that it was very different for the access cards...
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: [Duke3D] Failure to apply translation to keycards.

Postby Gez » Sun May 02, 2021 12:21 pm

Just for reference, the fix is in the newrenderer branch.
Gez
 
 
 
Joined: 06 Jul 2007

Re: [Duke3D] Failure to apply translation to keycards.

Postby Graf Zahl » Sun May 02, 2021 1:17 pm

The bug was also only in the newrenderer branch.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests