weird sprite clipping bug with animated brightmaps

Moderator: GZDoom Developers

weird sprite clipping bug with animated brightmaps

Postby Nell Blackfield » Tue Jan 11, 2022 3:02 am

I was using gzdoom 4.7.1 with the vulkan renderer, didn't test with opengl.

I had "smart" sprite clipping enabled. The bug occurs with "always" and "smarter" but not "never" iirc

Apparently, using HD textures ("NeuralUpscale2x_v2.0.pk3") and some custom brightmaps ("bmplus_vanilla.pk3" but with "iwad" flags removed) together results in sprite clipping errors when brightmaps aren't specified for certain frames of looping animated sprites.

When the brigthmaps and hd textures were both enabled, the armor and health bonus would clip into the ground for one frame and look like they are bobbing up and down.

The bug didn't occur when using the brightmaps pk3 only or the textures pk3 only.

This is important: apparently, "bmplus_vanilla.pk3" has brightmap .png files for every frame of the animations except the first frame. Adding a brightmap .png for the first frame fixed the issue.

To be more specific: I worked around the bug by editing the .bm files in "bmplus_vanilla.pk3." "brightmaps/sprites/doom.bm" didn't say to map any .png files for bon1a0 and bon2a0, like this:

"brightmap sprite bon1a0
{
disablefullbright
}

brightmap sprite bon1b0
{
map "brightmaps/sprites/doom/bon1b0.png"
disablefullbright
}

brightmap sprite bon1c0
{
map "brightmaps/sprites/doom/bon1c0.png"
disablefullbright
}

brightmap sprite bon1d0
{
map "brightmaps/sprites/doom/bon1d0.png"
disablefullbright
}"

I created files in "brightmaps/sprites/doom" "bon1a0.png" and "bon2a0.png" and added "map "brightmaps/sprites/doom/bon1a0.png"" under "brightmap sprite bon1a0 {...":

"brightmap sprite bon1a0
{
map "brightmaps/sprites/doom/bon1a0.png"
disablefullbright
}

brightmap sprite bon1b0
{
map "brightmaps/sprites/doom/bon1b0.png"
disablefullbright
}

brightmap sprite bon1c0
{
map "brightmaps/sprites/doom/bon1c0.png"
disablefullbright
}

brightmap sprite bon1d0
{
map "brightmaps/sprites/doom/bon1d0.png"
disablefullbright
}"

and likewise for bon2a0. This stopped the armor and health from clipping weirdly for one frame.

Hope this helps?
Nell Blackfield
 

Return to Vulkan Renderer Bugs

Who is online

Users browsing this forum: No registered users and 0 guests