GZDoom 4.1.0 Released

News about ZDoom, its child ports, or any closely related projects.
[ZDoom Home] [Documentation (Wiki)] [Official News] [Downloads] [Discord]
[🔎 Google This Site]

[Tap Here for Mobile-Friendly Forums]

Moderator: GZDoom Developers

Re: GZDoom 4.1.0 Released

Postby Kroc » Tue Apr 30, 2019 5:15 pm

The ZScript in the GZDoom.pk3 that ships with the binary causes deprecation warnings at startup; this is a bit of a nuisance as it looks like the WAD your playing might be broken!
User avatar
Kroc
PortaDOOM, DOOM-Crusher
 
Joined: 02 Oct 2016
Github ID: Kroc
Operating System: Windows 10/8.1/8 64-bit
Graphics Processor: Intel (Modern GZDoom)

Re: GZDoom 4.1.0 Released

Postby Rachael » Tue Apr 30, 2019 8:44 pm

This has already been reported and fixed. If it bothers you that much just open gzdoom.pk3:zscript.txt and change the top line to `version "4.0"` - that's a temporary workaround until the next version is available which has the more proper fix.
User avatar
Rachael
Webmaster
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Graphics Processor: nVidia with Vulkan support

Re: GZDoom 4.1.0 Released

Postby NightFright » Wed May 01, 2019 2:17 am

Could you please elaborate a bit more on the reasons for the doom.doom1/2 lump filter change (and why this one specifically and not any other)?
Also I assume the old syntax will keep working for the time being to avoid breaking mod compatibility? If it is like that, switching to the new syntax right away would mean your mod would only work in 4.1.0 or newer while otherwise it still works with a much wider range of GZDoom versions.
User avatar
NightFright
 
Joined: 02 May 2008
Location: Germany

Re: GZDoom 4.1.0 Released

Postby _mental_ » Wed May 01, 2019 3:35 am

NightFright wrote:Could you please elaborate a bit more on the reasons for the doom.doom1/2 lump filter change (and why this one specifically and not any other)?

viewtopic.php?t=62030
_mental_
 
 
 
Joined: 07 Aug 2011

Re: GZDoom 4.1.0 Released

Postby NightFright » Wed May 01, 2019 3:40 am

I see. So it's to avoid conflicts with Freedoom. Very well. Other than that, it's normal that gzdoom.pk3 yields quite a few warnings due to deprecated included code on startup?
User avatar
NightFright
 
Joined: 02 May 2008
Location: Germany

Re: GZDoom 4.1.0 Released

Postby _mental_ » Wed May 01, 2019 3:45 am

NightFright wrote:Other than that, it's normal that gzdoom.pk3 yields quite a few warnings due to deprecated included code on startup?

Is there any problem with the search function on the forum? viewtopic.php?t=64486 and viewtopic.php?t=64487.
_mental_
 
 
 
Joined: 07 Aug 2011

Re: GZDoom 4.1.0 Released

Postby NightFright » Wed May 01, 2019 3:49 am

Alright then. My bad.
User avatar
NightFright
 
Joined: 02 May 2008
Location: Germany

Re: GZDoom 4.1.0 Released

Postby Rachael » Wed May 01, 2019 5:12 am

NightFright wrote:Other than that, it's normal that gzdoom.pk3 yields quite a few warnings due to deprecated included code on startup?

Holy shit! How blind are you?!

Have you seen the two posts just before your post at the top of this very page?

:? Very disappointed.
User avatar
Rachael
Webmaster
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Graphics Processor: nVidia with Vulkan support

Re: GZDoom 4.1.0 Released

Postby Rachael » Wed May 01, 2019 11:05 am

Temporarily locking because for some odd reason people are unable to read:



I don't want to constantly babysit this topic. We have ways of reporting issues - and they work - this topic is not one of them.
User avatar
Rachael
Webmaster
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Graphics Processor: nVidia with Vulkan support

Previous

Return to ZDoom (and related) News

Who is online

Users browsing this forum: No registered users and 1 guest

cron