Vulkan enabled DR4 (or GZdoom) crashes after save

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE/EDuke32/Raze? Did your computer break? Ask here.

Moderator: GZDoom Developers

Forum rules
Contrary to popular belief, we are not all-knowing-all-seeing magical beings!

If you want help you're going to have to provide lots of info. Like what is your hardware, what is your operating system, what version of GZDoom/LZDoom/whatever you're using, what mods you're loading, how you're loading it, what you've already tried for fixing the problem, and anything else that is even remotely relevant to the problem.

We can't magically figure out what it is if you're going to be vague, and if we feel like you're just wasting our time with guessing games we will act like that's what you're really doing and won't help you.
maf93
Posts: 12
Joined: Fri Mar 19, 2021 11:07 am

Vulkan enabled DR4 (or GZdoom) crashes after save

Post by maf93 »

I'm playing DR4 1.21 Fianl (I know some don't like the look, but I find it to be a nice change of pace).

I must Enable Vulkan (vid_enablevulkan=1) to get the weapons to fully show (only the part around the hand is visible and not fully rendered). Also objects lose their 3D look and are flat (as reported in other posts). Enabling Vulkan crashes the game, most of the time, when I save it on my PC but not on my laptop. My PC has Intel Graphics UHD 770 and Radeon RX 640. The problem happens with either display adapter. My laptop has an Intel Iris XE, and as mentioned the problem does not happen.

Are there any settings that I can change in GZdoom to fix the crashing after a save while Vulkan is enabled on the PC?

Or is there a way to use the latest GZdoom with DR4 (it's using v4.1.3) to test? I tried just replacing gzdoom.exe in the DR4 folder with the latest gzdoom.exe download, but it reports all sorts of missing files.

This is what happens when I save. Technically you can still play, you just can't see anything. Sometimes I can do several consecutive saves and it doesn't happen.
[imgur]https://i.imgur.com/gb5Xunh.png[/imgur]

Thanks for any insight.
yum13241
Posts: 781
Joined: Mon May 10, 2021 8:08 pm
Preferred Pronouns: He/Him
Operating System Version (Optional): EndeavorOS (basically Arch)
Graphics Processor: Intel with Vulkan/Metal Support

Re: Vulkan enabled DR4 (or GZdoom) crashes after save

Post by yum13241 »

Report the bug to the DR4 developer. Modified/old versions of GZDoom are not supported.

I think you might have some VRAM problems. Try switching the graphics card you use.

Return to “Technical Issues”