GZDoom freezes on Arch and Ubuntu when either hosting or joing local multiplayer

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE/EDuke32/Raze? Did your computer break? Ask here.

Moderator: GZDoom Developers

Forum rules
Contrary to popular belief, we are not all-knowing-all-seeing magical beings!

If you want help you're going to have to provide lots of info. Like what is your hardware, what is your operating system, what version of GZDoom/LZDoom/whatever you're using, what mods you're loading, how you're loading it, what you've already tried for fixing the problem, and anything else that is even remotely relevant to the problem.

We can't magically figure out what it is if you're going to be vague, and if we feel like you're just wasting our time with guessing games we will act like that's what you're really doing and won't help you.
Posts: 1
Joined: Fri May 19, 2023 11:35 am
Operating System Version (Optional): SteamOS 3.4.6 / Windows 10
Graphics Processor: ATI/AMD with Vulkan/Metal Support

GZDoom freezes on Arch and Ubuntu when either hosting or joing local multiplayer

Post by zeroaim »

Hi everyone,

About 6 months ago I managed to get cross-platform multiplayer working between Steam Deck (Arch Linux) and Windows 10 machines, both locally and online, without much effort.
All it took was making sure the right ports were open for the host machine and that was it. It ran flawlessly.

Recently I had my old Steam Deck RMA'd with a new one and wanted to play so multiplayer again. However, all versions of GZDoom that I've tried up until the latest one freeze when trying to host or join a game.
There is no log window that appears during launch (it does if I launch SP) even though a normal looking log file is generated in GZDoom directory when I enable autoexec.cfg, and GZDoom remains idle (not frozen) as a process in the System monitor, but nothing actually happens. I've already been able to connect 2 Windows 10 machines both ways over my local network with no issues, so it doesn't seem its a networking issue.

At first I simply wanted to blame SteamOS, but I also tried hosting/joining a game from a clean Ubuntu installation running on one of my PC's and to my surprise that distro shows the exact same behavior.
No log windows when hosting/joining a multiplayer game. Just an idling GZDoom process. I also made sure that both Linux installs don't have issues with firewall permissions (turns out SteamOS doesn't even come with one).

Could it be that I'm missing some kind of network dependency in Linux that I'm not aware of? I have no idea what could be the issue at this point.

Any help or suggestions are very welcome

Return to “Technical Issues”