Autosave does not respect user settings!

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.
yum13241
Posts: 782
Joined: Mon May 10, 2021 8:08 pm
Preferred Pronouns: He/Him
Operating System Version (Optional): EndeavorOS (basically Arch)
Graphics Processor: Intel with Vulkan/Metal Support

Autosave does not respect user settings!

Post by yum13241 »

Expected behavior: Autosave settings are respected.

Actual behavior: They aren't.

What I mean is:

1. The ZScript version of Autosave does not care for disableautosave.
2. If you have an existing save, the name gets overridden.

Corruption Cards is the perfect example.
1. Set disableautosave to 2.
2. Start a new game, and pick a card.
3. Name the save. "Bug test" is a good choice.
4. Beat a map. MAP01 of Doom II is a good choice.
5. Pick a new card.
6. The autosave got overridden. It's now called Autosave blah....
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 49096
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Autosave does not respect user settings!

Post by Graf Zahl »

yum13241
Posts: 782
Joined: Mon May 10, 2021 8:08 pm
Preferred Pronouns: He/Him
Operating System Version (Optional): EndeavorOS (basically Arch)
Graphics Processor: Intel with Vulkan/Metal Support

Re: Autosave does not respect user settings!

Post by yum13241 »

i should flag that as [user error] cuz CC has an option to disable autosaves. But it's still weird it's allowed to execute.

Return to “Closed Bugs [GZDoom]”