[4.8.0+] "Sound in Background" does nothing

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.
Yarn366
Posts: 61
Joined: Fri Mar 02, 2018 11:48 pm
Preferred Pronouns: He/Him

[4.8.0+] "Sound in Background" does nothing

Post by Yarn366 »

Specifically, I'm referring to Sound Options -> Advanced options -> Sound in Background. Starting with GZDoom 4.8.0, changing this option to On has no effect; the sound is still paused when the game window is minimized or otherwise loses focus.

I managed to narrow the problem down to commit 12ed24d066a819a128a54e2359fd0e2d48f641fe.

In case it's relevant, I'm running Windows 10 64-bit.
User avatar
Rachael
Posts: 13523
Joined: Tue Jan 13, 2004 1:31 pm
Preferred Pronouns: She/Her

Re: [4.8.0+] "Sound in Background" does nothing

Post by Rachael »

That commit does exactly what it says.

Try changing i_pauseinbackground to fix the issue.

The game is paused when the window loses focus and when that happens the sound pauses too, regardless of the setting. This is intentional and will not be changed. If you want the sound to continue, the game just needs not be paused, and that's what i_pauseinbackground changes for you.

Return to “Closed Bugs [GZDoom]”