Unable to map MWheelUp=+lookup

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE/EDuke32/Raze? Did your computer break? Ask here.

Moderator: GZDoom Developers

Forum rules
Contrary to popular belief, we are not all-knowing-all-seeing magical beings!

If you want help you're going to have to provide lots of info. Like what is your hardware, what is your operating system, what version of GZDoom/LZDoom/whatever you're using, what mods you're loading, how you're loading it, what you've already tried for fixing the problem, and anything else that is even remotely relevant to the problem.

We can't magically figure out what it is if you're going to be vague, and if we feel like you're just wasting our time with guessing games we will act like that's what you're really doing and won't help you.
Guest

Unable to map MWheelUp=+lookup

Post by Guest »

Hello and thanks for the help,
I'd like to use the mouse-wheel to look-up and look-down.

In lzdoom.ini under "[Doom.Bindings]", I've tried changing to:
MWheelUp=+lookup
MWheelDown=+lookdown
It failed

Within the game, I've also tried customizing the "look up" and "look down" actions to map to the mouse wheel.
Unfortunately, it also failed.

I can successfully map "+lookup" and "+lookdown" to keys, but not to "MWheelUp" and "MWheelDown".
So I assume that I'm doing something wrong.

I'd appreciate guidance.
Thank you.
User avatar
drfrag
Vintage GZDoom Developer
Posts: 3113
Joined: Fri Apr 23, 2004 3:51 am
Location: Spain

Re: Unable to map MWheelUp=+lookup

Post by drfrag »

You can't do that in old GZDoom versions, must be an old bug.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48543
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Unable to map MWheelUp=+lookup

Post by Graf Zahl »

You cannot bind the mouse wheel to 'button' actions (i.e. the ones starting with '+'.)
These require a key to be held down, but the mouse wheel cannot be held down so these buttons never register as 'pressed'.

Return to “Technical Issues”