Xim's GZDoom3 for Classic Doom (Update OCT/27/23)

Projects that alter game functions but do not include new maps belong here.
Forum rules
The Projects forums are only for projects. If you are asking questions about a project, either find that project's thread, or start a thread in the General section instead.

Got a cool project idea but nothing else? Put it in the project ideas thread instead!

Projects for any Doom-based engine (especially 3DGE) are perfectly acceptable here too.

Please read the full rules for more details.
User avatar
Xim
Posts: 2086
Joined: Fri Feb 20, 2009 2:46 pm
Location: somewhere with trees

Re: Xim's GZDoom3 for Classic Doom (Update MAR/31/23)

Post by Xim »

Still working on the next update, but I've released a little spin-off I put together that I got distracted making. Hope you enjoy!

Download GZ-D33D here!
Dudejo
Posts: 23
Joined: Thu Jun 15, 2023 10:01 pm

Re: Xim's GZDoom3 for Classic Doom (Update MAR/31/23)

Post by Dudejo »

Is it just me or some of the texture replacements make Doom vanilla levels look like a NES game?
User avatar
Xim
Posts: 2086
Joined: Fri Feb 20, 2009 2:46 pm
Location: somewhere with trees

Re: Xim's GZDoom3 for Classic Doom (Update OCT/27/23)

Post by Xim »

New update.

Changes from last version:
Spoiler:
User avatar
RevanGarcia
Posts: 90
Joined: Sat Oct 17, 2015 4:57 pm
Preferred Pronouns: He/Him
Operating System Version (Optional): Windows 10
Location: UberHECK

Re: Xim's GZDoom3 for Classic Doom (Update OCT/27/23)

Post by RevanGarcia »

Let's go!
Armage
Posts: 38
Joined: Wed Jun 29, 2022 8:07 pm

Re: Xim's GZDoom3 for Classic Doom (Update OCT/27/23)

Post by Armage »

Hi Xim, how are you? First, congratulations for your amazing mod :D ! I downloaded this mod 2 years ago, 2021.

And i stopped with Doom mods, and i'm back today. But when i go to update your mod and test, i get this error message (your mod was working before in LZDoom, but now unfortunately not): Xim-Doom3-world.pk3:zscript/ddzd3_classes.zs, line 15: Unknown flag 'Weapon.NOAUTOSWITCHTO'
Execution could not continue.
1 errors, 0 warnings while compiling Xim-Doom3-world.pk3:zscript.zs

Another error i get if i use before version of world with other updated parts of mod: Warning: ZScript version mismatch. 4.7.1 required but only 4.6.1 supported.
Xim-Doom3-enemies.pk3:zscript.txt, line 10: Unknown flag 'SEEFRIENDLYMONSTERS'
Execution could not continue.
1 errors, 0 warnings while compiling Xim-Doom3-enemies.pk3:zscript.txt

Can you please make an small patch for your mod works in LZDoom?

Thanks for your attention and waiting for your response.

Return to “Gameplay Mods”