Sound sequence cant be heared but still take channel [4.4.2]

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.
User avatar
Apeirogon
Posts: 1603
Joined: Mon Jun 12, 2017 12:57 am

Sound sequence cant be heared but still take channel [4.4.2]

Post by Apeirogon »

Sound sequence attached to sector with script takes sound channel even if camera that can hear this sound is way to far away from sector with this sound sequence.

Load file and start new game. Right at the start you should hear "pistol shot" sound sequence attached to sector. Open console and type "stat sound". It would show that one channel currently busy by this "pistol shot" sequence. Now type in console "warp 30000 0 0" for example, or any other big numbers. After warping sound statistics will still shows that one channel currently still "play" something. It dosent looks right.
sec_seq_chan_bug.zip
Cant say is it a my error or engine bug, since sound sequence related functions dont documented well.
You do not have the required permissions to view the files attached to this post.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48519
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Sound sequence cant be heared but still take channel [4.

Post by Graf Zahl »

This is perfectly normal for looped sounds. They need to stick around in case the player gets close again.

Return to “Closed Bugs [GZDoom]”