Is HRTF Working in 4.3.3?

Post bugs that have to do with sound and/or in-game music here.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!
User avatar
Barry Burton
Posts: 87
Joined: Tue Sep 03, 2019 2:20 pm

Is HRTF Working in 4.3.3?

Post by Barry Burton »

Last night I was plaiyng GZD 4.3.3 through headphones. It seemed I was only hearing normal, standard stereo so I switched HRTF from Auto to On but it didn't seen to change anything.

I don't know if it's just a glitch in the matrix or just me (most likely) but I thought I'd ask. I remember using 'phones regularly last year and I found hthe HRTF implementation quite effective.

EDIT: Using built-in OpenAL found in GZD, Fluidsynth for music and GZD 4.3.3 on Windows 10 Pro
User avatar
Chris
Posts: 2879
Joined: Thu Jul 17, 2003 12:07 am
Graphics Processor: ATI/AMD with Vulkan/Metal Support

Re: Is HRTF Working in 4.3.3?

Post by Chris »

Run "snd_status" in the console, and show what it says. I probably should add the HRTF status to that, or provide some other way to show what's currently in use (separate from what the option is set to). But what is there may help shed light on what's going on.
User avatar
Barry Burton
Posts: 87
Joined: Tue Sep 03, 2019 2:20 pm

Re: Is HRTF Working in 4.3.3?

Post by Barry Burton »

Coolio. I won't have the chance 'til tonight but I'll report back.
User avatar
Barry Burton
Posts: 87
Joined: Tue Sep 03, 2019 2:20 pm

Re: Is HRTF Working in 4.3.3?

Post by Barry Burton »

Apologies for the delayed response. I finally have time to load up the game. I did as asked and I've uploaded a screenshot. I hope this is what you were looking for. I have no idea what any of it means!
You do not have the required permissions to view the files attached to this post.

Return to “Audio/Music Bugs”