Aetherius (GZD 4.7.1) (Doom/Heretic/Hexen/Strife) [hiatus]

Projects that alter game functions but do not include new maps belong here.
Forum rules
The Projects forums are only for projects. If you are asking questions about a project, either find that project's thread, or start a thread in the General section instead.

Got a cool project idea but nothing else? Put it in the project ideas thread instead!

Projects for any Doom-based engine (especially 3DGE) are perfectly acceptable here too.

Please read the full rules for more details.
User avatar
Marisa the Magician
Posts: 3886
Joined: Fri Feb 08, 2008 9:15 am
Preferred Pronouns: She/Her
Operating System Version (Optional): (btw I use) Arch
Graphics Processor: nVidia with Vulkan support
Location: Vigo, Galicia

Re: Aetherius [(GZDoom 4.6.0+) for Doom/Heretic/Hexen/Strife

Post by Marisa the Magician »

Compiles zscript to native code instead of interpreted bytecode, for better performance. Can be disabled by putting +vm_jit 0 on the command line.

Anyway, this kind of error definitely needs to be looked into. Seems to be related to the player from what I've been able to dig, but I can't pinpoint the offending line.
User avatar
TheBeardedJedi
Posts: 63
Joined: Thu Mar 28, 2013 9:03 pm

Re: Aetherius [(GZDoom 4.6.0+) for Doom/Heretic/Hexen/Strife

Post by TheBeardedJedi »

Misfit, thanks for updating this mod. I noticed the main branch being improved in the past 16 hours after a month break on github. Question: could you please look into the levelup system for flora? I wrote a command that gives the chararacter a huge amount of experiessence, in order to quickly level up to 200 with equipment. Though this was working flawlessly in GZDoom 4.6, 4.6.1 prevents leveling up or gaining exp this way past the 110 mark, even with all equipment and the ingame settings allowing flora to reach level 200. Thanks so much.
User avatar
Lord Misfit
Posts: 222
Joined: Wed Dec 27, 2006 8:13 pm
Preferred Pronouns: He/Him
Graphics Processor: nVidia with Vulkan support
Location: Canton, OH

Re: Aetherius [(GZDoom 4.6.0+) for Doom/Heretic/Hexen/Strife

Post by Lord Misfit »

Just tried it [on 4.6.1], and the "pukename expcheat [#]" command I do is fine. It's just that at some point, I might have bumped up the EXP requirements of post-level 100 requirements [because it was feeling too easy to level up too often above level 100], so you might need to add another 0 or two to your value to max it at 200 in one go.
User avatar
drfrag
Vintage GZDoom Developer
Posts: 3142
Joined: Fri Apr 23, 2004 3:51 am
Location: Spain

Re: Aetherius [(GZDoom 4.6.1+) for Doom/Heretic/Hexen/Strife

Post by drfrag »

Marisa Kirisame wrote:That log tells me it's crashing on a call to SpawnHealth(). I've reproduced the same crash too. Doesn't happen with JIT disabled.
For me it also crashes on both LZDoom and the vintage build inside SpawnHealth too.
This line:

Code: Select all

	int defhealth = StartHealth ? StartHealth : GetDefault()->health;

Code: Select all

>	gzdoom.exe!AActor::SpawnHealth() Line 7234	C++
 	gzdoom.exe!AF_AActor_SpawnHealth(VMValue * param, int numparam, VMReturn * ret, int numret) Line 753	C++
 	gzdoom.exe!VMNativeFunction::NativeScriptCall(VMFunction * func, VMValue * params, int numparams, VMReturn * returns, int numret) Line 311	C++
 	[External Code]	
 	gzdoom.exe!VMCall(VMFunction * func, VMValue * params, int numparams, VMReturn * results, int numresults) Line 576	C++
 	gzdoom.exe!AActor::Tick() Line 3648	C++
 	gzdoom.exe!AF_DThinker_Tick(VMValue * param, int numparam, VMReturn * ret, int numret) Line 839	C++
 	gzdoom.exe!VMNativeFunction::NativeScriptCall(VMFunction * func, VMValue * params, int numparams, VMReturn * returns, int numret) Line 311	C++
 	[External Code]	
 	gzdoom.exe!VMCall(VMFunction * func, VMValue * params, int numparams, VMReturn * results, int numresults) Line 576	C++
 	gzdoom.exe!DThinker::CallTick() Line 851	C++
 	gzdoom.exe!DThinker::TickThinkers(FThinkerList * list, FThinkerList * dest) Line 766	C++
 	gzdoom.exe!DThinker::RunThinkers() Line 620	C++
 	gzdoom.exe!P_Ticker() Line 159	C++
 	gzdoom.exe!G_Ticker() Line 1229	C++
 	gzdoom.exe!TryRunTics() Line 2004	C++
 	gzdoom.exe!D_DoomLoop() Line 1061	C++
 	gzdoom.exe!D_DoomMain_Internal() Line 2889	C++
 	gzdoom.exe!D_DoomMain() Line 2901	C++
 	gzdoom.exe!DoMain(HINSTANCE__ * hInstance) Line 963	C++
 	gzdoom.exe!wWinMain(HINSTANCE__ * hInstance, HINSTANCE__ * nothing, wchar_t * cmdline, int nCmdShow) Line 1291	C++
edrobot
Posts: 1
Joined: Sun Sep 05, 2021 3:38 pm
Graphics Processor: nVidia with Vulkan support

Re: Aetherius [(GZDoom 4.6.1+) for Doom/Heretic/Hexen/Strife

Post by edrobot »

I'm having trouble running this with the Doom64 compatability patch. For one thing, I had trouble figuring out WHICH version of Doom64 to use, since the compatability patch didn't say, and through trial and error I think it's supposed to be for Doom64 CE https://www.moddb.com/mods/doom-ce/down ... ll-version, since nothing else I tried came close to working. But even after getting Doom64 CE to run, it wouldn't work with Aetherius because of the following error:

Code: Select all

OS: Windows 10 (NT 10.0) Build 19043
    
M_LoadDefaults: Load system defaults.
Using program directory for storage
W_Init: Init WADfiles.
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/gzdoom.pk3, 634 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/game_support.pk3, 2514 lumps
 adding ./DOOM64.IWAD, 1668 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/DOOM64.CE.ipk3, 2693 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/DOOM64.CE.Base.pk3, 6030 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/DOOM64.CE.Base.pk3:pla2.wad, 53 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/DOOM64.CE.Base.pk3:pla3.wad, 53 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/DOOM64.CE.Base.pk3:pla4.wad, 53 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/DOOM64.CE.Addon.BGM.Extended.pk3, 42 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/DOOM64.CE.Addon.BGM.Arranged.pk3, 117 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/DOOM64.CE.Addon.SFX.HQ.pk3, 145 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/DOOM64.CE.Addon.GFX.Extra.pk3, 4 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/DOOM64.CE.Addon.GFX.Decals.pk3, 5 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/DOOM64.CE.Addon.GFX.Brightmaps.pk3, 968 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/DOOM64.CE.Addon.GFX.PBR.pk3, 5653 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/DOOM64.CE.Addon.GFX.Parallax.pk3, 779 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/DOOM64.CE.Addon.GFX.Upscale.pk3, 5710 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/DOOM64.CE.Maps.LostLevels.pk3, 29 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/game_widescreen_gfx.pk3, 121 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/DV-DS-ComboPack-master, 16763 lumps
 adding C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/Compatability Packs/DV-DS-CompatPacks2-master/Doom64, 37 lumps

Execution could not continue.

Script error, "C:/Users/edrob/Desktop/gzdoom-4-6-1-Windows-64bit/DV-DS-ComboPack-master/:cvarinfo.txt" line 486:
cvar 'sv_strafetilt' already exists
Am I doing something wrong?
User avatar
PlayerLin
Posts: 582
Joined: Sun Nov 11, 2007 4:20 am
Graphics Processor: nVidia with Vulkan support
Location: XinZhuang, XinBei/New Taipei City(Former Taipei County), Taiwan.

Re: Aetherius (GZD 4.7.1) (Doom/Heretic/Hexen/Strife) [hiatus]

Post by PlayerLin »

Well, I know it maybe bad idea about using latest GZDooM dev build to play the mod as it still labeled as 4.7.1...since I saw the mod did still updated recently in Github so I guessed the mod would still based on latest versions of GZDooM...And most of the mod seems still working fine after I play it around for some times, with some minor problems(like the custom crosshair for Flona's Sceptre only works on Heretic mode, and never works on other modes/compatible patches, not sure if it's known problem or not) but most of it looks like works fine to me...maybe some monsters may still stuck in their monster closets for some reasons or items drops on unreachable area on some custom maps with compatible patches...also the item count bug about Aetherius's special items(if a count item become a Aetherius's special items like Fiona's special equipments, they don't count toward the item count so cannot get 100% items if that happens on a level)...again not really game-breaking bugs.


I just try play Aetherius with Going Down compatible patch, in Map29: Demolition, the normal way to finish the level is kill the Spider Mastermind: the normal one will died shortly after attack it and spawn a red, looks like "pissed off" one. When kill the "pissed off" SM, the IoS explosions should happens and the level will ends. But for some reasons, in Aetherius' version of this map, it never happens so I cannot finish the level...I just use "changemap map30" console command to warp to next map, not sure if it's the mod's problem or the compatible patch's problem...

Return to “Gameplay Mods”