Cannot get .sf2 file to work

Discuss anything ZDoom-related that doesn't fall into one of the other categories.

Cannot get .sf2 file to work

Postby sonicdoommario » Wed Aug 18, 2010 1:10 am

Back in the day, I used to play Doom on my grandmother's Windows 95 machine. Her soundcard was an AWE32. Doom sounded a little like this:

http://www.youtube.com/watch?v=f2kBgPB0 ... re=related

I ran into the file 1mgm.sf2, and I followed the instruction on how to use it with ZDoom. Here is the path I put in the timidity.exe.cfg file:

dir C:\Users\Administrator.TIMMY\Documents\Timmy's Files and Documents\Doom\1mgm.sf2

If I try soundfont <directory>, I get this error message:

TIMIDITY.CFG: LINE 6: Bad soundfont option files

Is there another step I'm missing? I'd really love to get this working.

I tried following the readme, and messing around with the timidity_pipes option and resetting the sound.

Thanks and any help would be greatly appreciated.
sonicdoommario
 
Joined: 31 Jul 2004
Location: Attleboro, MA

Re: Cannot get .sf2 file to work

Postby NeuralStunner » Wed Aug 18, 2010 1:39 am

The path contains spaces, have you tried putting path\file in quotes?
User avatar
NeuralStunner
Not "Neutral"
 
 
 
Joined: 21 Jul 2009
Location: capital N, capital S, no space
Discord: NeuralStunner#4201
Operating System: Windows Vista/7/2008 64-bit
Graphics Processor: nVidia (Modern GZDoom)

Re: Cannot get .sf2 file to work

Postby sonicdoommario » Wed Aug 18, 2010 1:42 am

So would it be something like this:

soundfont"C:\Users\Administrator.TIMMY\Documents\Timmy's Files and Documents\Doom\1mgm.sf2"

Or

soundfont C:\Users\Administrator.TIMMY\Documents\Timmy's Files and Documents\Doom\"1mgm.sf2"

Or would I need to use dir instead of soundfont?
sonicdoommario
 
Joined: 31 Jul 2004
Location: Attleboro, MA

Re: Cannot get .sf2 file to work

Postby NeuralStunner » Wed Aug 18, 2010 1:57 am

This should do:
Code: Select allExpand view
dir "C:\Users\Administrator.TIMMY\Documents\Timmy's Files and Documents\Doom"
soundfont "1mgm.sf2"


Also I put thmy soundfont path at the start of ZDoom's default TiMidity.cfg:
Spoiler:
User avatar
NeuralStunner
Not "Neutral"
 
 
 
Joined: 21 Jul 2009
Location: capital N, capital S, no space
Discord: NeuralStunner#4201
Operating System: Windows Vista/7/2008 64-bit
Graphics Processor: nVidia (Modern GZDoom)

Re: Cannot get .sf2 file to work

Postby sonicdoommario » Wed Aug 18, 2010 3:41 pm

Got it to work - thanks!
sonicdoommario
 
Joined: 31 Jul 2004
Location: Attleboro, MA

Re: Cannot get .sf2 file to work

Postby NeuralStunner » Wed Aug 18, 2010 4:12 pm

Coolness! Might I recommend this soundfont? :D
User avatar
NeuralStunner
Not "Neutral"
 
 
 
Joined: 21 Jul 2009
Location: capital N, capital S, no space
Discord: NeuralStunner#4201
Operating System: Windows Vista/7/2008 64-bit
Graphics Processor: nVidia (Modern GZDoom)

Re: Cannot get .sf2 file to work

Postby Princess Viscra Maelstrom » Sat Sep 18, 2010 1:52 pm

I'm sorry to bump this, but when I try to do the exact same thing to run a soundfont with Timidity, it doesn't work. It appears to load correctly, but there's no sound coming out. Help?
User avatar
Princess Viscra Maelstrom
 
Joined: 04 Dec 2008
Location: plergleland

Re: Cannot get .sf2 file to work

Postby Gez » Sat Sep 18, 2010 1:59 pm

Have you followed the instructions from the TiMidity++ article? Set it as the midi device in sound options? Then used the Restart sound command? Have you tried setting up FluidSynth instead?
Gez
 
 
 
Joined: 06 Jul 2007

Re: Cannot get .sf2 file to work

Postby Princess Viscra Maelstrom » Sat Sep 18, 2010 4:12 pm

I found the problem; I have to put a CVAR in the console. However, I've tried different combinations in the console, and nothing happened. What exaxctly do I have to type in the console?
User avatar
Princess Viscra Maelstrom
 
Joined: 04 Dec 2008
Location: plergleland

Re: Cannot get .sf2 file to work

Postby Gez » Sat Sep 18, 2010 4:32 pm

Code: Select allExpand view
timidity_exe d:/games/doom/zdoom/timidity/timidity.exe


Adapt the path as appropriate.
Gez
 
 
 
Joined: 06 Jul 2007

Re: Cannot get .sf2 file to work

Postby Princess Viscra Maelstrom » Sat Sep 18, 2010 6:49 pm

That's strange. I pointed it to the folder where Timidity++ is, but it still doesn't work. What the hell?
User avatar
Princess Viscra Maelstrom
 
Joined: 04 Dec 2008
Location: plergleland

Re: Cannot get .sf2 file to work

Postby Gez » Sun Sep 19, 2010 12:51 am

You need to point it to the exe, not just the folder.
Gez
 
 
 
Joined: 06 Jul 2007

Re: Cannot get .sf2 file to work

Postby Princess Viscra Maelstrom » Sun Sep 19, 2010 4:41 am

I DID point it to the exe, but still nothing happened. Does a message pop up in the console if it's input correctly?
User avatar
Princess Viscra Maelstrom
 
Joined: 04 Dec 2008
Location: plergleland

Re: Cannot get .sf2 file to work

Postby Gez » Sun Sep 19, 2010 4:49 am

No.

But when you set it incorrectly, then select TiMidity++ as the MIDI device, then use snd_reset, you get an error message telling you to "please set the timidity_exe cvar to the location of timidity++", so if you don't get that, it's that it's set correctly.

Don't forget you need to use snd_reset (or the "restart sound" entry in the sound options menu) after a change. Otherwise, it still uses the same stuff as before because these cvars are only checked when the sound system is initialized.
Gez
 
 
 
Joined: 06 Jul 2007

Re: Cannot get .sf2 file to work

Postby Princess Viscra Maelstrom » Sun Sep 19, 2010 7:22 am

I do do so. I set the Timidity cvar to the location of the Timidity exe and restart sound. No dice. What..? I honestly don't understand what I'm doing wrong. I follow the instructions from A to B to C, and it doesn't work.

EDIT: Got it to work, finally!
User avatar
Princess Viscra Maelstrom
 
Joined: 04 Dec 2008
Location: plergleland


Return to General

Who is online

Users browsing this forum: No registered users and 4 guests