SLADE Discussion - Latest: v3.2.5 (19/Dec/2023)

Any utility that assists in the creation of mods, assets, etc, go here. For example: Ultimate Doom Builder, Slade, WadSmoosh, Oblige, etc.
Forum rules
The Projects forums are ONLY for YOUR PROJECTS! If you are asking questions about a project, either find that project's thread, or start a thread in the General section instead.

Got a cool project idea but nothing else? Put it in the project ideas thread instead!

Projects for any Doom-based engine (especially 3DGE) are perfectly acceptable here too.

Please read the full rules for more details.
User avatar
pompom454
Posts: 2
Joined: Thu Dec 14, 2023 8:42 am
Operating System Version (Optional): Windows 10

Re: SLADE Discussion - Latest: v3.2.4 (21/June/2023)

Post by pompom454 »

Hi. I have been using SLADE before. However, a few days ago, it stopped working along with SRB2 (OpenGL), and SRB2Kart (OpenGL). Here's the error it spat out.
Version: 3.2.4 (x64)
No current action

Operating System: Windows 10 (build 19045), 64-bit edition
Graphics Vendor: OpenGL not initialised
Graphics Hardware: OpenGL not initialised
OpenGL Version: OpenGL not initialised

Stack Trace:
0: [unknown location] [unknown:775477792]
1: [unknown location] glapi_set_nop_handler
2: [unknown location] stw_get_framebuffer_resource
3: [unknown location] stw_get_framebuffer_resource
4: [unknown location] st_context_teximage
5: [unknown location] glapi_noop_enable_warnings
6: [unknown location] stw_make_current
7: [unknown location] stw_make_current
8: [unknown location] DrvSetContext
9: [unknown location] wglSwapLayerBuffers
10: [unknown location] wglMakeCurrent
11: [unknown location] [unknown:3122523344]
12: [unknown location] [unknown:3122511471]
13: [unknown location] [unknown:3122510581]
14: [unknown location] [unknown:3122507470]
15: [unknown location] [unknown:3122506139]
16: [unknown location] [unknown:3122441495]
17: [unknown location] [unknown:3119623495]
18: [unknown location] [unknown:3119599329]
19: [unknown location] [unknown:3118223473]
20: [unknown location] [unknown:3118082136]
21: [unknown location] [unknown:3117978738]
22: [unknown location] [unknown:3117947912]
23: [unknown location] [unknown:3117947607]
24: [unknown location] [unknown:3113333613]
25: [unknown location] [unknown:3113358404]
26: [unknown location] [unknown:3117945509]
27: [unknown location] [unknown:3117933695]
28: [unknown location] [unknown:3113949764]
29: [unknown location] [unknown:3119694343]
30: [unknown location] [unknown:3122929332]
31: [unknown location] [unknown:3123094703]
32: [unknown location] [unknown:3123097603]
33: [unknown location] [unknown:3123098465]
34: [unknown location] [unknown:3123094490]
35: [unknown location] [unknown:3123097450]
36: [unknown location] [unknown:3124155811]
37: [unknown location] [unknown:3124182259]
38: [unknown location] [unknown:3124192904]
39: [unknown location] [unknown:3124218069]
40: [unknown location] CallWindowProcW
41: [unknown location] DispatchMessageW
42: [unknown location] IsDialogMessageW
43: [unknown location] [unknown:3124189471]
44: [unknown location] [unknown:3125525967]
45: [unknown location] [unknown:3125526050]
46: [unknown location] [unknown:3125524140]
47: [unknown location] [unknown:3123581955]
48: [unknown location] [unknown:3123582490]
49: [unknown location] [unknown:3122934807]
50: [unknown location] [unknown:3123620284]
51: [unknown location] [unknown:3123083400]
52: [unknown location] [unknown:3127914718]
53: [unknown location] BaseThreadInitThunk
54: [unknown location] RtlUserThreadStart

Last Log Messages:
Base resource loaded
Loading game configurations
SLADE Initialisation OK
Error: Can't open registry key 'HKLM\Software\Wow6432Node\GOG.com' (error 2: The system cannot find the file specified.)
Error: Can't read value of 'HKLM\Software\Wow6432Node\GOG.com\DefaultPackPath' (error 2: The system cannot find the file specified.)
Checking for updates...
Latest stable release: v3.2.4
Latest beta release: v3.2.0 beta 4
Already up-to-date
Opening archive C:\Users\user9\Videos\SRB2 Kart\addons\MusicPatch.wad
I dunno why this happened, but I did uninstall some apps a few days ago. I did reinstall them, but nothing happened.
yum13241
Posts: 781
Joined: Mon May 10, 2021 8:08 pm
Preferred Pronouns: He/Him
Operating System Version (Optional): EndeavorOS (basically Arch)
Graphics Processor: Intel with Vulkan/Metal Support

Re: SLADE Discussion - Latest: v3.2.4 (21/June/2023)

Post by yum13241 »

Your drivers need reinstalling.
User avatar
pompom454
Posts: 2
Joined: Thu Dec 14, 2023 8:42 am
Operating System Version (Optional): Windows 10

Re: SLADE Discussion - Latest: v3.2.4 (21/June/2023)

Post by pompom454 »

yum13241 wrote:
> Your drivers need reinstalling.
Actually, it's a registry problem. There was a folder and a string value. It couldn't find those things. So, I added that stuff. Now, it's an AppData folder problem. I've asked a friend and they'll help me with it soon.
User avatar
-Stormwalker-
Posts: 15
Joined: Sun May 08, 2022 11:40 am

Re: SLADE Discussion - Latest: v3.2.5 (19/Dec/2023)

Post by -Stormwalker- »

I just updated my SLADE version to 3.2.5. The new update broke the application. This is on a Linux machine, running Manjaro. I receive this error when I right-click on a linedef and select "Properties". Then the application bombs out.

ASSERT INFO:
/usr/src/debug/wxwidgets/wxWidgets-3.2.4/include/wx/withimages.h(254): assert ""Assert failure"" failed in GetBitmapBundle(): Image index specified, but there are no images.

Did you forget to call SetImages()?

BACKTRACE:
[1] wxDataViewTreeCtrl::AppendContainer(wxDataViewItem const&, wxString const&, int, int, wxClientData*)
[2] wxEvtHandler::ProcessEventIfMatchesId(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&)
[3] wxEvtHandler::SearchDynamicEventTable(wxEvent&)
[4] wxEvtHandler::TryHereOnly(wxEvent&)
[5] wxEvtHandler::ProcessEventLocally(wxEvent&)
[6] wxEvtHandler::ProcessEvent(wxEvent&)
[7] wxEvtHandler::SafelyProcessEvent(wxEvent&)
[8] wxMenuBase::SendEvent(int, int)
[9] g_closure_invoke
[10] g_signal_emit_valist
[11] g_signal_emit
[12] gtk_widget_activate
[13] gtk_menu_shell_activate_item
[14] g_signal_emit_valist
[15] g_signal_emit
[16] gtk_main_do_event
[17] g_main_context_iteration
[18] gtk_main_iteration
[19] wxWindow::DoPopupMenu(wxMenu*, int, int)
[20] wxWindowBase::PopupMenu(wxMenu*, int, int)
[21] wxEvtHandler::ProcessEventIfMatchesId(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&)
[22] wxEvtHandler::SearchDynamicEventTable(wxEvent&)
[23] wxEvtHandler::TryHereOnly(wxEvent&)
[24] wxEvtHandler::ProcessEventLocally(wxEvent&)
[25] wxEvtHandler::ProcessEvent(wxEvent&)
[26] wxEvtHandler::SafelyProcessEvent(wxEvent&)
[27] g_closure_invoke
[28] g_signal_emit_valist
[29] g_signal_emit
[30] gtk_main_do_event
[31] g_main_loop_run
[32] gtk_main
[33] wxGUIEventLoop::DoRun()
[34] wxEventLoopBase::Run()
[35] wxAppConsoleBase::MainLoop()
[36] wxEntry(int&, wchar_t**)
[37] main
[38] __libc_start_main
User avatar
generic name guy
Posts: 122
Joined: Wed Nov 11, 2020 3:25 pm
Graphics Processor: nVidia with Vulkan support
Location: Brazil

Re: SLADE Discussion - Latest: v3.2.5 (19/Dec/2023)

Post by generic name guy »

SLADE doesn't detect common ZScript file extensions, like zs, zsc and zc, making me select them manually, is there a list or something of file extensions for automatically detecting the language? It doesn't even detect them as a text file.
User avatar
NeuralStunner
 
 
Posts: 12326
Joined: Tue Jul 21, 2009 12:04 pm
Preferred Pronouns: He/Him
Graphics Processor: nVidia with Vulkan support
Location: capital N, capital S, no space

Re: SLADE Discussion - Latest: v3.2.5 (19/Dec/2023)

Post by NeuralStunner »

generic name guy wrote: Thu Jan 18, 2024 12:17 pm SLADE doesn't detect common ZScript file extensions, like zs, zsc and zc, making me select them manually, is there a list or something of file extensions for automatically detecting the language? It doesn't even detect them as a text file.
Anything under the zscript directory in your archive should be detected as such, if you're putting them in root I recommend putting them under zscript/ instead.
User avatar
generic name guy
Posts: 122
Joined: Wed Nov 11, 2020 3:25 pm
Graphics Processor: nVidia with Vulkan support
Location: Brazil

Re: SLADE Discussion - Latest: v3.2.5 (19/Dec/2023)

Post by generic name guy »

NeuralStunner wrote: Fri Jan 19, 2024 11:52 am
generic name guy wrote: Thu Jan 18, 2024 12:17 pm SLADE doesn't detect common ZScript file extensions, like zs, zsc and zc, making me select them manually, is there a list or something of file extensions for automatically detecting the language? It doesn't even detect them as a text file.
Anything under the zscript directory in your archive should be detected as such, if you're putting them in root I recommend putting them under zscript/ instead.
Nope, they're in a ZScript folder.
TheDoomedArchvile
Posts: 8
Joined: Fri Aug 10, 2018 9:54 pm

Re: SLADE Discussion - Latest: v3.2.5 (19/Dec/2023)

Post by TheDoomedArchvile »

Quick question
Is there a way to make the guide lines when having a graphic selected to a different color than black? Or the background different colors? It's a bit difficult for me to see the guide lines against the background and it would be nice to change the colors if it's possible to set them.

Return to “Creation, Conversion, and Editing”