Problem with Thing_Spawn

Archive of the old editing forum
Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. This forum is archived - please use this set of forums to ask new questions.

Problem with Thing_Spawn

Postby Xaser » Mon Jul 21, 2003 1:39 pm

I am currently working on a project called Danger Zone that consists of 7 levels, all linked together in a hub, and have been having problems with the Thing_Spawn special. In level 2, in a silver room with 2 slopes in it, you're supposed to trigger a line that will spawn a baddie on the ledge above, but when you cross the line, nothing happens. Yet, Strangely enough, a while back, I made a wad called Kill Stuff, and I made a large room with tons of switches that would spawn a different type of monster on the central teleporter depending on which of the switches you pressed. The switches do a Thing_Spawn to a map spot on the central teleporter, so the baddies would teleport there. The Thing_Spawn special worked in Kill Stuff, but it won't do anything on Danger Zone map02. The only difference is that on Danger Zone map02, the line is activated by walking over it, and on Kill Stuff, it's activated by a switch. I can't figure out what i'm doing wrong.

The two wads are below for anyone who wants to take a closer look.

If you don't want to help me, at least download Kill Stuff, it Rocks!!!
User avatar
Xaser
anarchivist
 
 
 
Joined: 20 Jul 2003

Postby Graf Zahl » Mon Jul 21, 2003 2:30 pm

Your problem is the map spot's z-coordinate. It is placed 16 units below the ceiling so there is simply not enough space for the monster and it isn't spawned. The Lost Soul you are trying to spawn is 56 units high so you must lower the map spot by at least 40 units.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Postby Xaser » Mon Jul 21, 2003 3:03 pm

THANK YOU!!! I always forget about the Z coordinate, mainly because Danger Zone is my first project that uses the Z. I never used the Z in kill stuff, so that's why it worked. Thanx VERY MUCH!!! Now I can continue on map03...

EDIT: Damn Misspellings...
User avatar
Xaser
anarchivist
 
 
 
Joined: 20 Jul 2003


Return to Editing (Archive)

Who is online

Users browsing this forum: No registered users and 2 guests