[Not a ZDoom bug] Crasklish...playing MP3s along with ZDoom

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.
User avatar
Curunir
Posts: 1040
Joined: Sun Nov 02, 2003 11:24 am
Graphics Processor: ATI/AMD with Vulkan/Metal Support

Crasklish sound when playing MP3s along with Zdoom

Post by Curunir »

I'm not sure if this is really a bug and I'd like to say sorry beforehand if it doesn't fit in this category.
The point is, when you play mp3s (in Winamp, in my case) and then start Doom, sound is cracklish and distorted. It may be just a limitation of fmod.dll or something. The strange thing is that the sound is all right when I play an .ogg file in Winamp.
I hate to pester, but I think it would be nice to have clear sound while listening to custom music while playing.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 49066
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Post by Graf Zahl »

Using WinAmp in parallel to play music for ZDoom is a bad idea. This stuff is almost guaranteed to cause problems. Convert the MP3's and OGG's to a WAD and use them in ZDoom internally that should fix your problem
User avatar
HotWax
Posts: 10002
Joined: Fri Jul 18, 2003 6:18 pm
Location: Idaho Falls, ID

Post by HotWax »

This may just be due to a slow CPU trying to do too much at once. MP3's have to be decoded so they can be played, and that takes processor cycles. If you really want to keep doing this, you could try setting Winamp to use a higher thread priority, but that might cause your other programs (including ZDoom) to become sluggish.
User avatar
Chris
Posts: 2940
Joined: Thu Jul 17, 2003 12:07 am
Graphics Processor: ATI/AMD with Vulkan/Metal Support

Post by Chris »

Also if you set ZDoom's sampling frequency to less than whatever the MP3 is (usually 44khz), the the audio output frequency is changed as well, so anything else playing the audio (like Winamp) will notice a sudden drop in playback frequency.
User avatar
randi
Site Admin
Posts: 7746
Joined: Wed Jul 09, 2003 10:30 pm

Post by randi »

This is all very soundcard dependant. I have never had a problem playing anything in the background with WinAmp while running ZDoom. That is with a Vortex 2, a SoundBlaster Audigy, and nForce2 Audio. (I'd also include the GUS PnP in that list, but I can't remember what it was like anymore.)

But since you can play MP3 and Vorbis with ZDoom anyway, why use WinAmp?
User avatar
Hirogen2
Posts: 2033
Joined: Sat Jul 19, 2003 6:15 am
Graphics Processor: Intel with Vulkan/Metal Support
Location: Central Germany

Post by Hirogen2 »

randy wrote:But since you can play MP3 and Vorbis with ZDoom anyway, why use WinAmp?
To have some music playing even when ZDoom is not active all the time?
BTW, works for me(tm).
User avatar
Curunir
Posts: 1040
Joined: Sun Nov 02, 2003 11:24 am
Graphics Processor: ATI/AMD with Vulkan/Metal Support

Post by Curunir »

I'd like to have Winamp playing so that I can blow stuff to chunks to the sound of Thyrfing or something :roll:
Anyway, obviously, my sound card = teh poop, since it works for others. It's onboard so, no surprise.
User avatar
HotWax
Posts: 10002
Joined: Fri Jul 18, 2003 6:18 pm
Location: Idaho Falls, ID

Post by HotWax »

Try this at the console next time, Cur:

] changemus "c:\my music\Thyrfing's kick-ass song.mp3"

Or, if you'd rather use an entire playlist:

] playlist "c:\my music\playlists\Thyrfing.m3u"

BTW, who the hell is Thyrfing?
User avatar
Curunir
Posts: 1040
Joined: Sun Nov 02, 2003 11:24 am
Graphics Processor: ATI/AMD with Vulkan/Metal Support

Post by Curunir »

First of all, Waxie, thanks a lot for the console advice. Does just what I wanted Winamp to :)
Also, Thyrfing are a "they" :) Here and here.

omg, viking metal, lol

Return to “Closed Bugs [GZDoom]”