[Fixed] Chaingun problems with new Zdoom

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.
User avatar
Lexus Alyus
Posts: 4220
Joined: Tue Jul 15, 2003 5:07 pm
Location: Nottingham, UK

Chaingun problems with new Zdoom

Post by Lexus Alyus »

I know that the chaingun was fixed against illigal modifications, etc... but my new chaingun won't go through it's muzzle flash animations :-(. When you fire it just sticks on the first flash animation. It's basically just modified graphix, which operate identically to the old chaingun but it fires faster and it slows down after you fire (like the quake 2 chaingun). How can I solve this?

Oh, by the way, I'm using beta 59.

:evil:
User avatar
Xaser
 
 
Posts: 10772
Joined: Sun Jul 20, 2003 12:15 pm

Post by Xaser »

I just noticed the exact same thing with my ROTT Weapon Modification. The MP-40 (Chaingun Replacement) Looks like shit because you only see one firing frame. Please fix!!!
Cyb
Posts: 912
Joined: Tue Jul 15, 2003 5:12 pm

Post by Cyb »

this also happens with the normal doom chaingun, it doesn't animate any longer
User avatar
Curunir
Posts: 1040
Joined: Sun Nov 02, 2003 11:24 am
Graphics Processor: ATI/AMD with Vulkan/Metal Support

Post by Curunir »

The BFG also lost its animation frames :?
User avatar
Xaser
 
 
Posts: 10772
Joined: Sun Jul 20, 2003 12:15 pm

Post by Xaser »

Curunir wrote:The BFG also lost its animation frames :?
Huh? The BFG works fine for me.
User avatar
Curunir
Posts: 1040
Joined: Sun Nov 02, 2003 11:24 am
Graphics Processor: ATI/AMD with Vulkan/Metal Support

Post by Curunir »

Well, the lights on it flash, but there's no recoil for me.
User avatar
Kate
... in rememberance ...
Posts: 2975
Joined: Tue Jul 15, 2003 8:06 pm

Post by Kate »

and by "recoil" he means the bfg used to move back after firing, which it no longer does.
User avatar
Softie
Posts: 104
Joined: Fri Dec 05, 2003 9:18 am
Location: Sweden

Post by Softie »

Yes, have that problem too with 59, worked in 57.
User avatar
Lexus Alyus
Posts: 4220
Joined: Tue Jul 15, 2003 5:07 pm
Location: Nottingham, UK

Post by Lexus Alyus »

I read in the changelog that Randy fixed the chaingun to prevent illigal flash frames... this is probably a negotive side effect from that... It would be nice ifg it was fixed cus my chaingun doesn't look as cool as it did... but it still looks cool :-D.

:twisted:
User avatar
randi
Site Admin
Posts: 7746
Joined: Wed Jul 09, 2003 10:30 pm

Post by randi »

Fixed.

Return to “Closed Bugs [GZDoom]”