Any texture pack don't work in GZDoom.

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE/EDuke32/Raze? Did your computer break? Ask here.

Moderator: GZDoom Developers

Forum rules
Contrary to popular belief, we are not all-knowing-all-seeing magical beings!

If you want help you're going to have to provide lots of info. Like what is your hardware, what is your operating system, what version of GZDoom/LZDoom/whatever you're using, what mods you're loading, how you're loading it, what you've already tried for fixing the problem, and anything else that is even remotely relevant to the problem.

We can't magically figure out what it is if you're going to be vague, and if we feel like you're just wasting our time with guessing games we will act like that's what you're really doing and won't help you.
VVanTuz2OO2
Posts: 3
Joined: Thu Nov 24, 2022 11:04 am
Preferred Pronouns: He/Him
Operating System Version (Optional): many
Graphics Processor: Intel (Legacy GZDoom)

Any texture pack don't work in GZDoom.

Post by VVanTuz2OO2 »

Hello everybody.

I know that DHTP has some compatibility problems, but I did tried many versions of it. But other texture related mods should work at least. Doomenator's Dark Textures won't work too. The only ones working is JFO's for HUD and text. \ UPD: any of the Cacodemon's Texture pack do not work either!

I tried all of the following:
- Dragged on executable
- .bat file gzdoom.exe -file anymod.pk3
- ZDL
- Autoload (checked many times that I did everything right) in ini. Btw I had tough times separating lines in that generating ini, what a mess.
- Tried it on basic ZDoom

I did tried running from the the same directory, tried separating IWADS and mods - results are identical.

Any suggestions? I had also read countless posts from here and Zandronum forums, but none of that helped me solve it.
yum13241
Posts: 461
Joined: Mon May 10, 2021 8:08 pm
Preferred Pronouns: He/Him
Operating System Version (Optional): EndeavorOS (basically Arch)
Graphics Processor: Intel with Vulkan/Metal Support

Re: Any texture pack don't work in GZDoom.

Post by yum13241 »

Have you tried using the "skins" folder? Make it if it doesn't exist. Anything in there has to end in .wad. (even if it's a PK3)

Make sure you aren't trying to run it from Program Files, and make sure you're using the right IWAD.
User avatar
wildweasel
Moderator Team Lead
Posts: 21576
Joined: Tue Jul 15, 2003 7:33 pm
Preferred Pronouns: He/Him
Operating System Version (Optional): Win10 22H2, Win11 22H2, macOS 11.7
Graphics Processor: nVidia with Vulkan support

Re: Any texture pack don't work in GZDoom.

Post by wildweasel »

Check your console output and see if the file you're loading is actually being loaded (you'll see it next to the IWAD).

Return to “Technical Issues”