Zeta Touch - Android port of Raze & EDuke32

Posts: 1
Joined: Tue Jan 03, 2023 5:29 pm
Preferred Pronouns: He/Him
Operating System Version (Optional): Windows 10; Android 9

Re: Zeta Touch - Android port of Raze & EDuke32

Post by EmpireFaust »

First time poster, longtime lurker here, I've been following these various OpenTouch Android projects since the Delta Touch early days. I hate to ask something so specific, Emile, but the .CON-parser for Zeta Touch's eDuke seems to be different and much more sensitive than the standalone eDuke on my laptop...why is that, and can this be changed to be closer to the PC version, at some point? Certain mods that run fine on PC won't load here, and it's always due to an "Error Compiling .CON Files." Chiefly, I tried to play one of my favorites today, "LameDukeX" (brings the LameDuke levels and weapons to regular D3D) and had this problem again, which prompted me to sign up here in order to ask this.

Editing to remove previous edit (Duke Xtreme CONs do work, just had to move all the contents of SPMAPS and DMMAPS to one shared directory)
Last edited by EmpireFaust on Tue Jan 03, 2023 5:49 pm, edited 2 times in total.
User avatar
Posts: 17
Joined: Sun Apr 16, 2023 9:21 pm
Preferred Pronouns: He/Him
Graphics Processor: Not Listed

Re: Zeta Touch - Android port of Raze & EDuke32

Post by iHaveYourGun »

Here's a bug and a question:
Bug: for some reason when I try to launch Blood apparently it keeps saying this

BLOOD.PAL: file too small

is there any to fix this and is there a solution to it because this keeps showing up as soon as I launch it

Question: Is there a way to add add-ons to ANY game like Duke pukem (sarcasm) and anything else? I know its a lot to ask and this is gonna be a long ass post but yea I just need help ight? Thanks!

future edit: nvm I fucking hate my life and I got blood to work...ALSO ANOTHER BUG: NOW it CrAsHeS every time I start the level (oh and this happens to every game except duke nukem)

YET ANOTHER FUTURE EDIT?!?!?: so nvm from the last future edit I fix the bug where it crashes and now I'm back on square 1. Still the same issue as before: BLOOD.PAL: file too small! SO PLEAAAASE.....if anyone has a solution for this problem please private message me.

TF ARE WITH THESE FUTURE EDITS?!?!!!!?!: Good news I got blood to work but NOW when I launch cryptic passage, the entire game glitches and only shows a black screen. NoOoOw I need help with that!

GO TO HELL FUTURE EDITS!!!!: so I think cryptic passage is fixed now and I no longer need help. I will be deleting this tomorrow.
You do not have the required permissions to view the files attached to this post.
Last edited by iHaveYourGun on Sun Aug 13, 2023 7:11 pm, edited 3 times in total.
User avatar
Posts: 271
Joined: Tue Apr 10, 2018 8:14 am

Re: Zeta Touch - Android port of Raze & EDuke32

Post by Phredreeke »

If emile were to port those games to Android, I would expect them to be a separate app, not part of Zeta Touch. The two games on the Quake 3 engine might fit Quad Touch but as I said earlier in this topic I'm not sure he wants to touch those given the circumstances of their release. I have no idea about the first Jedi Knight other than a reverse engineered port exists, OpenJKDF2.

Dark Forces would be a candidate for porting (recently it was ported to the Amiga), using the force engine. Lucius himself has expressed no interest in doing an Android port however he welcomes others to do so if they're willing to maintain it.

Return to “Projects”