[solved] map started via gzdb doesnt show actors

Ask about mapping, UDMF, using DoomBuilder/editor of choice, etc, here!

Moderator: GZDoom Developers

Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.
User avatar
Posts: 1458
Joined: Tue Oct 20, 2015 12:50 pm
Graphics Processor: nVidia with Vulkan support
Location: Kozolupy, Bohemia

[solved] map started via gzdb doesnt show actors

Post by ramon.dexter »

What happened? Yesterday I was editing with no problems, today I started gzdb and ... what? When I start the map in testing mode (with F9 key), it loads with no errors, but the actors are gone. Not that the graphics are not working, but the actors itself are not present (I know where some blocking actors are, and the blocking is not working, so the actor is not present). When I load the files normally (drag-and-drop the files over gzdoom.exe), is´t loads correctly with the actors appearing where they have to be.
Whats going on? I checked the testing setting in gzdb if I havent checked to dont show actors, but no.

Its not a big issue. But I'm mjust used to the F9 testing, so drag and dropping the files everytime I want to test would slow me down a bit :(


I am an idiot.

Yep, the faul was caused by user... I created new skill settings and I completely overlook teh thing that spawnfilter has predefined fixed words - I just defined myself and BAM - the actors were gone. Because I told the engine to not show the actors. It hit me when I started the map without difficulty set and then with difficulty set.

Case closed, this thred is considered solved

Return to “Mapping”