Joystick Strafing Bug

Sat Oct 11, 2003 11:46 pm

I don't want to sound redundant, but I don't see this bug mentioned here (I posted about this bug in the old forum). I'm talking about the latest version of ZDoom. The player is strafing in opposite directions. When I try to go left, the player goes right, and vice versa. I tried both the "Inverted" and "Not Inverted" settings but it does the same thing.

Sun Oct 12, 2003 12:02 am

try calibrating your joystick.

Sun Oct 12, 2003 8:36 am

try calibrating your joystick.


I did that and it's still doing the same thing. I'm using version 2-0-42 and it's working fine, so I don't know when this bug cropped up. Does anyone else have this problem?

Sun Oct 12, 2003 8:55 am

.
Oh goodness, I gave up using a joystick after the second time I played DOOM.
Then when I got my butt kicked every time when I just used the keyboard,
I became a convert to keyboard and mouse.
.

Sun Oct 12, 2003 9:01 am

Daggorath wrote:I'm using version 2-0-42...


We're at 2-0-47i now, maybe upgrading will fix the problem?

Sun Oct 12, 2003 10:13 am

I bet 2.0.42 was not any worse than 2.0.47 in joystick handling, however you might want to try 'dxdiag' (DirectX Diagnostics) after having the joystick set up and calibrated in Control Panel.

Sun Oct 12, 2003 2:07 pm

Come on guys, read his whole post and make sure your reply is appropriate before responding, eh?

Zell: The symptoms of an uncalibrated joystick would certainly not be to have the left and right directions reversed...

Kappes: He didn't ask for an opinion on his control method. :P

Xaser: He said 2.0.42 works fine, which seems to indicate that the newer version he's trying to use is causing the problem.

I just tested joystick control assigning strafe to the X-axis of my controller and it worked as expected. When Strafing is set to "Not Inverted" in the Joystick Options menu, left strafes left and right strafes right. When it's set to Inverted, it's the other way around. So, Works For Me(TM). Just as a suggestion, try making sure your stick works in other games. Maybe it's a hardware or Windows issue.

If it's ZDoom-only, try changing other joystick settings to see if something is screwing things up. The raw cvars that affect joystick control can be listed using the following command at the console:

] cvarlist *joy*

See if anything set there pops out at you as incorrect. If all else fails, try deleting the INI and setting things up from scratch.

Sorry I couldn't be more helpful, I'm not used to using a joystick in ZDoom so I'm not sure what could be causing your problem.

Sun Oct 12, 2003 3:39 pm

I was using version 47 and 47i by the way. I notice something else strange about it. Under joystick options in the axis sensitivity section, all the options are set to "Inverted" by default (except for strafing). But the funny thing is, the player moves in non-inverted ways eg. turning left does turn left and moving forward does move forward etc. The controls and options are reversed.

My joysticks work in other games. Dxdiag reported no problems. My joysticks are in fact gamepads, DirectPad Pro and Gravis GamePad (4 buttons). Both have the same problem.

My computer is a Pentium 233 MMX using Windows 98 SE.

Thu Oct 23, 2003 10:12 am

Sorry to bump this but I have a similar problem that I've posted about before.

In 2.0.42 my Gamepad Pro works fine, but in 47 upwards I rotate very slowly anticlockwise through 360 degrees. It is not a joystick problem and is very, very annoying.

The new support for joysticks since 47 doesn't appear to have worked too well, and I preferred the simpler set up of before.

Thu Oct 23, 2003 1:36 pm

pritch wrote:Sorry to bump this but I have a similar problem that I've posted about before.

In 2.0.42 my Gamepad Pro works fine, but in 47 upwards I rotate very slowly anticlockwise through 360 degrees. It is not a joystick problem and is very, very annoying.

The new support for joysticks since 47 doesn't appear to have worked too well, and I preferred the simpler set up of before.


Sorry, but that does sound like a calibration issue.

Thu Oct 23, 2003 3:37 pm

HotWax wrote:
pritch wrote:Sorry to bump this but I have a similar problem that I've posted about before.

In 2.0.42 my Gamepad Pro works fine, but in 47 upwards I rotate very slowly anticlockwise through 360 degrees. It is not a joystick problem and is very, very annoying.

The new support for joysticks since 47 doesn't appear to have worked too well, and I preferred the simpler set up of before.


Sorry, but that does sound like a calibration issue.

Well if it is I certainly cannot find a way to deal with it. It works fine in any earlier version of zdoom and other ports of Doom and other games for that matter, so..

Thu Oct 23, 2003 5:48 pm

pritch wrote:In 2.0.42 my Gamepad Pro works fine, but in 47 upwards I rotate very slowly anticlockwise through 360 degrees. It is not a joystick problem and is very, very annoying.

The "deadzone" on the gamepad is too small. What that means is that the "stick" does not perfectly center, so values below a certain threshold need to be thrown out or you'll get movement when you don't want it. I thought calibrating in the game controllers control panel was supposed to take care of that, but apparently not.

Re: Joystick Strafing Bug

Fri Oct 24, 2003 9:33 pm

Daggorath wrote:When I try to go left, the player goes right, and vice versa.

Works for me.

pritch wrote:I rotate very slowly

I just added back dead zone values. They default to 0.15 like they did in earlier versions of ZDoom.

Fri Oct 24, 2003 10:24 pm

It looks like this is a Windows/hardware compatibility issue for me. Oh well. Maybe getting a new computer will fix the problem.