[Duplicates] Pointblank shot does not frag the imp

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.
User avatar
Kappes Buur
 
 
Posts: 4007
Joined: Thu Jul 17, 2003 12:19 am
Location: British Columbia, Canada

Pointblack shot does not frag the imp

Post by Kappes Buur »

.
I seem to recall, that this had been mentioned earlier. But for the life of me I cannot find the post where it was mentioned.

The imp stands right in front of me, so close that it is zapping me. I shoot it, pointblank, with the SSG. Nothing. I shoot it again. Nothing. Then I draw back a little bit, then shoot and finally the imp goes down.

That appears to be map independent, as it happened while playing different maps.

But the puzzling thing is, that it does not happen all the time.

I am using ZDoom 2.0.52
.
User avatar
Malphas
Posts: 33
Joined: Wed Jul 16, 2003 2:14 am
Location: The Ultimate Warzone (Bronx, NYC)

Post by Malphas »

In a similarly related case, I noticed that my weapons seem to have been stronger than I last recall. I charged at a Hell Knight with my rocket launcher, expecting 3 rockets will take it down.

One was all it took. :shock:

I wonder if coming at it from an angle may have something to do with it... :?:
User avatar
The Ultimate DooMer
Posts: 2109
Joined: Tue Jul 15, 2003 5:29 pm
Location: Industrial Zone

Post by The Ultimate DooMer »

This has always been in ZDoom - for some reason it makes the old shots-going-through-monsters bug worse than it was in vanilla. So imps take more than one shell more often than not (whereas it should be one shell most of the time).

It is to do with angles, though.
User avatar
Hirogen2
Posts: 2030
Joined: Sat Jul 19, 2003 6:15 am
Github ID: jengelh
Operating System: RedHat-like Linux (RHEL, Fedora, CentOS, etc) 64-bit
Graphics Processor: Intel with Vulkan Support
Location: Central Germany

Post by Hirogen2 »

Remember that a shell is seven pellets, and AFAIK, like seven independent spread bullets.
User avatar
Enjay
 
 
Posts: 26403
Joined: Tue Jul 15, 2003 4:58 pm
Location: Scotland

Post by Enjay »

There was a recently reported and now fixed bug about the rocket damage.

http://forum.zdoom.org/viewtopic.php?t=989
User avatar
HotWax
Posts: 10002
Joined: Fri Jul 18, 2003 6:18 pm
Location: Idaho Falls, ID

Post by HotWax »

This is two separate issues that both deal with the blockmap. The first is a vanilla Doom bug that didn't properly check ALL blocks that an enemy was in when plotting a hitscan trace, which made the Imp harder to hit (OR it could have been the 20480 unit length bug that caused calculation overflows). Either way, both of those bugs have been fixed for the next version.

The second bug, in which an enemy takes more blast damage than it should, and thus goes down more quickly, is another blockmap bug, this one introduced in ZDoom, which caused blast damage that spanned multiple blocks to be applied multiple times, obviously incorrect, now fixed for the next version.
User avatar
Malphas
Posts: 33
Joined: Wed Jul 16, 2003 2:14 am
Location: The Ultimate Warzone (Bronx, NYC)

Post by Malphas »

Thanks for the heads-up, HotWax and Enjay. :)
User avatar
randi
Site Admin
Posts: 7728
Joined: Wed Jul 09, 2003 10:30 pm

Post by randi »

I assume this is duplicates of the bugs that have already been mentioned. If 2.0.53 still does it, post this again.

Return to “Closed Bugs”